21

I have a HP15 r007TX laptop with Debian 8 (Jessie) installed.

Whenever I close the lid and then reopen, the laptop stops working. It get's stuck showing a blank screen. From there nothing happens and I have to hard reboot it.

I even changed the setting to do nothing when laptop lid is closed and still have the issue.

  • Unfortunate this will be difficult to diagnose without more details. Which window manager? – slm May 3 '15 at 14:11
  • A small comment from my experience. Your laptop hasn't stopped working, only the screen. The process of sending a laptop to sleep and then waking it up is quite complex and a common glitch is that upon reactivating the screen it gets messed up. What I do sometimes is close the lid again, wait a moment, and then reopen it. Then the screen returns to normal again (sometimes after a few tries!). Please do not take my comment as a solution. Read some more about this. Your software, video card, drivers are all relevant so provide more information about your system. – undostres May 3 '15 at 15:23
  • @slm wmctrl -m gave Gnome Shell as the window manager.. – Anupam Basak May 3 '15 at 15:27
  • @undostres any solution to this?? – Anupam Basak May 3 '15 at 15:29
  • I've had tons of trouble with Debian Jessie and Stretch doing this on Mac Book Air and multiple versions of the Dell XPS 13. It makes Debian extremely unreliable. – Jeff Burdges Feb 7 '16 at 2:55
28

To disable the Lid Switch:

  1. Open the file /etc/systemd/logind.conf as root.

  2. Find this: HandleLidSwitch

  3. If it's commented, uncomment and change the value to ignore. The line after editing should be:

    HandleLidSwitch=ignore
    
  4. Restart computer and your problem should be gone. Or better restart logind service:

    sudo service systemd-logind restart
    

(Source)

  • Might want to mention, that this is because your laptop has a problem with suspension (could be suspend to disk or suspend to RAM). At least that's what I read from the related link. However my laptop doesn't suspend, and the screen is still blank occasionally after reopening. – CMCDragonkai Jul 3 '16 at 10:45
  • 2
    This did not work for me. The service command made my screen go black immediately. – luther Mar 18 '17 at 1:04
  • This fixed the issue of going into standby for me on Debian 9.5. I had disabled lid close actions in both regular system settings and in gnome-control-center, but after plugging in and out a secondary screen, it enabled itself, even though "perform lid closed action even with external monitors attached" was off as well. – Fabian Röling Sep 23 '18 at 9:11
  • It's funny that a 3 year old thread is still helpful.. XD – Anupam Basak Sep 24 '18 at 13:20
  • There's also an additional setting in screensaver->settings->lock settings. – Fabian Röling Feb 1 at 21:37
-1

You can try installing laptop-mode-tools if you haven't done so before.

I had the similar issues with my MBR.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.