I had some problems installing Linux mint and or any other Linux distribution in combination with Windows. When I booted my machine it would hang before the grub bootloader showed up. Now i have some free time I decided to give it another shot and even ended up having a successful dualboot with arch Linux and Windows 8.1.

I accomplished this result by removing my secondary hdd from my laptop and install both operating systems on my msata ssd. However when I insert this hdd again I am getting the same issue as explained above "hangs on welcome to grub".

So I pretty much narrowed down the issue to the fact that inserting my second hdd breaks my bootloader (removing the hdd solves the issue). But I am still not sure what causes my second hdd to break grub.

I completely formatted the hdd on another Windows 8.1 machine using the disk utility provided by Windows 8.1. Yet this did not solve my issue either.

I've had a dual boot with Ubuntu 12.04 & Windows 8.1 running just fine like half a year ago on the same configuration. Also when I use the default Windows 8.1 bootloader it works just fine (for Windows only obviously). I also tried installing Ubuntu 14.04 but the same issue here.

Does anyone know how to solve this issue. Could it be that Ubuntu 12.04 was using another version of grub?

Update 1

Output of sudo parted /dev/sdb print (tested in try ubuntu)

Number Start End Size Type File system Flags 1 1049kB 215GB 215GB primary ntfs 2 215GB 500GB 285GB primary ntfs

Update 2

I completely wiped the disk and used sudo shred -v /dev/sdb to make sure nothing on that disk could interfere with the booting of grub. I also tried another disk I had lying around but same issue here.

Update 3 So yeah, after running out of options with GRUB I tried installing Lilo as my last resort. IT WORKS! It might be a little slow but it is booting my system just fine :D

  • Post the output of parted /dev/second-hdd print please. – mbiber May 2 '15 at 14:28
  • Will do when I get home tomorrow – Sander Koenders May 2 '15 at 14:34
  • @mbiber Results are in my now updated post. – Sander Koenders May 3 '15 at 7:20
  • You should check your BIOS settings as this does not appear to be disk related. Check if you can disable that drive from boot order, or at least put it in last. – mbiber May 3 '15 at 17:53
  • @mbiber Tried that but didn't work, I am going to try lilo tonight – Sander Koenders May 3 '15 at 18:23

So I ended up installing LILO as bootloader which works just fine. It kinda confirms the theory that there might be something wrong with the newer versions of GRUB.

Here are the install instructions:

First remove GRUB bootloader:

sudo pacman -Rsn grub

For installing packages that are not listed in the arch repo by default we need development tools:

sudo pacman -S base-devel

Now download the tarbal from here and extract it using:

tar -xf lilo.tar.gz

Now cd into the newly created directory and install LILO using:

sudo makepkg -sci

Edit the lilo configuration file so everything points to the correct disk and partitions (check partitions with sudo fdisk -l. Also check this for reference.

sudo nano /etc/lilo.conf

Finally install LILO to your disk using:

sudo lilo

Remember to run the last command after every kernel update!

This might not be the actual answer to my question but atleast it solves the problem I was trying to deal with. I think I might help other people with this and therefore I am marking this as answer. Please feel free to post more possible solutions. If I have some free time I will try them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.