4

Today I wanted to upgrade my system from Debian Wheezy to Jessie. As first step I thought it is a good idea to upgrade the current wheezy-packages:

sudo apt-get update
sudo apt-get upgrade

... however on the "upgrade" command, I got an error (sorry, I only have the text in german):

Paketlisten werden gelesen... Fertig
E: Der Wert »stable« ist für APT::Default-Release ungültig, da solch eine Veröffentlichung in den Paketquellen nicht verfügbar ist.

A translation of the error could be:

E: The value "stable" is for APT::Default-Release is invalid, since such a release is not available in the package-sources.
4

The value for APT::Default-Release can be modified in:

/etc/apt/apt.conf/10defaultRelease

Since the "stable" version has changed from "wheezy" to "jessie", it is needed to replace "stable" with "oldstable" in that file. If you want to upgrade to jessie (and if you updated your sources.list), you can replace the string with "stable" again.

Edit:

When looking on a different debian-system, the file "10defaultRelease" does not even exist. It seems like this file is only needed if repositories of two different debian-versions are mixed.

  • 1
    Using /etc/apt/preferences to control things is possibly easier. That is what I use. – Faheem Mitha May 2 '15 at 12:28
  • 1
    Also, to avoid similar problems any time a new stable release comes out, it's better to use release code names (jessie, wheezy etc.) if you're using a specific stable release. – Stephen Kitt May 2 '15 at 15:38
  • I also do not have that file, nor /etc/apt/preferences – Rui F Ribeiro Nov 19 '15 at 12:36
  • 1
    Probably you dont use wheezy in that case. In jessie neither of them exists per default. There is a folder /etc/apt/preferences.d where you can create one. – Alex Nov 20 '15 at 10:58
  • In ubuntu, the file is /etc/apt/apt.conf.d/01ubuntu – pd12 Aug 11 '16 at 15:24
0

From: http://forums.debian.net/viewtopic.php?f=5&t=126806

At one time, you had a repository with the release name "stable-updates" in your sources, and set Synaptic to prefer packages from that repository in its settings. Then the repository was removed, and Synaptic is freaking out. (Sort of a bug, IMO) I believe that setting is in the /root/.synaptic/synaptic.conf file if you have a root account, and kmathern has come up with this code to fix the setting:

su -c "sed -i 's/DefaultDistro \".*\"/DefaultDistro \"\"/' /root/.synaptic/synaptic.conf"

-1

simply replacing oldstable with oldoldstable in the /root/.synaptic/synaptic.conf file did the trick

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.