8

How do I disable the beep/bell sound that is emitted in Secure Shell in Chrome OS? When certain commands fail, such as pressing backspace on an empty command line or on a failing tab autocompletion, I hear a very loud and annoying sound. It seems like a silly question, but I use the Secure Shell continuously and the sounds happen a lot.

I'm talking about the Secure Shell here that can be accessed when Chrome OS is in developer mode by pressing Ctrl+Alt+T and then typing 'shell'.

  • I don’t know what an omnibar is, but your terminal program should have an option to turn off the bell. – yellowantphil May 1 '15 at 11:46
  • For some reason I was certain that the beep also occurred on the omnibar, but it doesn't. Instead, it's only apparent in the Secure Shell. I've editted the question to make this clear. – Benjamin B. May 2 '15 at 13:49
11

I know this is an old question but I found this via google today and I thought I'd post an updated answer for anyone else stumbling into this page.

If you'd rather not write JavaScript, There is now a Profile Settings page that can be reached via ctrl+shift+p.

To remove the bell you can delete the value in the audible-bell-sound field.

| improve this answer | |
5

A friendly user of the chrome-os, Aseda, pointed me to the hterm/Secure Shell FAQ.

The audible bell can be disabled by opening the Javascript console by pressing Ctrl+Shift+J and then typing:

term_.prefs_.set('audible-bell-sound', '')
| improve this answer | |
  • If this solves your problem, you can click the check box to the left of the answer. – yellowantphil May 2 '15 at 14:34
  • Thanks for the reminder! Thing was that I had to wait for 20 hours before I could accept my own answer. I've done this now. Problem solved! :) – Benjamin B. May 3 '15 at 15:25
0

Thank you all for the good answers - the one by Kenny was easiest for me.

I just want to note some things that might find others find this question/answer page, since the alert sound might be going off under surprising circumstances, far away from where you're generating it, and be very annoying to people.

E.g you may use a chromebook, in dev mode, via the crosh terminal, to ssh in to a remote host. That host, of course, could be running any OS (Linux, Windows, MacOS etc). You can trigger the terminal bell / alert, e.g. in a shell window, at the beginning of the line, by hitting backspace, because there is no character to be erased. When you do, all the virtual terminals connected via ssh (and tmux etc) will get the alert, and any of them might be configured to make the alert sound. This is how bad (and mysterious) it can get:

  • On chromebook (in dev mode) open Terminal / secure shell (with the crosh prompt)
  • Connect (via shell command) to bash shell
  • Connect via ssh command to another host
  • Notice that backspace at the beginning of a line triggers the alert on the chromebook
  • Of course, hitting backspace directly on the host that you've ssh'd in to will also trigger the alert sound.
  • Leave your chromebook alone for a while, letting the screen blanks. But still, even though it look like it is off or in sleep mode, alerts triggered remotely still make noise on it, for a while at least!

If you actually close the lid of the chromebook, it will really go to sleep and won't make noise any more. Or if you disable the audible alert as described in other answers.

| improve this answer | |
0

Everything has been said, here is a summary:

Disable:

Open the JavaScript console (Control Shift J) and type:

term_.prefs_.set('audible-bell-sound', '')

Further detail in: /usr/share/chromeos-assets/crosh_builtin/js/nassh_deps.concat.js:

[hterm.PreferenceManager.categories.Sounds, 'lib-resource:hterm/audio/bell', 'url', 'URL of the terminal bell sound.  Empty string for no audible bell.']

Still, easier, there is the extension/application (hterm) which allows to do it in graphical mode:

https://chrome.google.com/webstore/detail/secure-shell/pnhechapfaindjhompbnflcldabbghjo?utm_source=chrome-app-launcher-info-dialog

Enable:

term_.prefs_.set('audible-bell-sound', 'lib-resource:hterm/audio/bell')
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.