1

I began by installing Debian from CDs this went smoothly and the system was working.

I then shut down and started again, GNOME was not loading at all so I used the commands as follows to get GNOME back:

$ sudo apt-get install gdm3 gnome-core
$ sudo apt-get install x-window-system-core

once this was completed I tried both:

$ sudo /etc/init.d/gdm3 start

and

$ startx

I can't remember which one worked for me but at the moment, GNOME will start up, I can logon but once logged on:

  1. The desktop background won't display and
  2. when I go into the applications the frequently used ones are visible but when I switch to "all apps" they are not shown at all though the animation when the "show apps" button is clicked shows them either swooping away or toward the button.

I have tried changing the icon theme, and also changing the GNOME version that is loaded at login but none of them fix this problem, I also tried a reinstall of the packages:

$ sudo apt-get install --reinstall gnome-core x-window-system-core gdm3

but none of them worked.

If anyone can shed light on getting GNOME working that would be great thank you!

  • I have installed Debian 8 and I can boot but the gdm3 log in screen won't show any background. Once logged in, the background image is displayed correctly. The gnome menus seem to be broken though: there is a lot of white space on the right of each menu entry. – Giorgio May 2 '15 at 7:54
  • could this be a bug with or an incorrect install do you think/guess? – Eoin May 4 '15 at 6:27
  • I thought about both options. Since it is a fresh install in which I picked some standard packages, I doubt that it is an incorrect install, but maybe I will try to re-install in a few days, just to be sure. It could also be a bug, since jessie has been released only a few days ago. I will keep upgrading and see if there is some bug fix that solves the problem. In the mean time I have followed some online documentation on how to set the greeter background image but I had not success: the greeter background is black. – Giorgio May 4 '15 at 8:21
  • ok no worries, I left it and going back to Ubuntu! I know it better though it may not be as lightweight! thanks anyway! – Eoin May 4 '15 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.