13

EDIT

A posteriori, the problem was most likely related to the one described here.


Original post

Until yesterday, Internet was just fine and I connected without much problems. I then disabled the network interface, trying to understand a little more how to manage these kind of things, issuing the command (wlp6s0 is my wireless network interface) :

#ip link set wlp6s0 down

The interface was successfully disabled as expected. Unfortunately, it didn't go back to an UP state since.

What I tried and other info:

1) The first thing I did was of course issuing the command

#ip link set wlp6s0 up

to bring the interface up. Doing this, no errors are given, but the interface remains DOWN, as shown by the output of

$ip link show

Looking with journalctl or dmesg however the only given error seems to be

$journalctl -xe | grep tail
...
IPv6: ADDRCONF (NETDEV_UP): wlp6s0: link is not ready 
...

What does this error mean?

2) I initially also had the netctl network manager. Thinking that could have been the source of the problem I uninstalled it with

#pacman -R netctl

And then proceeded to stop the netctl services I could find and removed them manually from

/etc/systemd/system/multi-user.target.wants

Nothing changed.

3) Following discussions on similar problems on the Ubuntu forums, I blacklisted the module wmi as explained in the link. Still no luck.

4) Searching around on similar issues reveals a common problem related to some hardware clock, which can be diagnosed with rfkill. This doesn't seem to be case though, as the output of rfkill list shows:

$rfkill list
0: nfc0: NFC
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

5) I also have Windows 7 on the same laptop (in dual boot). On Windows I can connect with no problems to my wireless network. So the problem isn't in the laptop hardware nor in the wireless network.

5
  • Probably you need to use iw to configure WiFi settings (e.g., network to connect to). Maybe something like wpa_supplicant to do authentication. Not sure if you can get the link to show up without that.
    – derobert
    Apr 30, 2015 at 7:29
  • 1
    First thing I would check (since it has bitten me before too) is as you are having this problem on a laptop, is whether there is a physical keyboard combination (probably brand specific) for dis- and enabling wifi. It might be that the "ip link" commands and the key combination are not in sync, as in, yes, you can disable wifi from the command line, but only enable it with the key combination.
    – JdeHaan
    Apr 30, 2015 at 7:36
  • @JdeHaan do you refer to the rfkill caveat which is mentioned in the arch wiki? If yes, I don't have the rfkill program installed so I'm not sure how to follow those instructions. Otherwise, is there a way to check if such a key combination exists from the terminal?
    – glS
    Apr 30, 2015 at 10:29
  • @glance Like I wrote, it is (hardware) brand specific. So check your keyboard for odd (off-colored) key texts or symbols. One of them might have a wifi like picture.
    – JdeHaan
    Apr 30, 2015 at 11:19
  • @JdeHaan there is no such thing that I can see. Is there no way to detect something like that from the terminal?
    – glS
    Apr 30, 2015 at 14:37

1 Answer 1

2

A bit late, but I managed to fix it by first killing all dhcpcd processes:

killall dhcpcd

Then when I had a look at ifconfig, it said that my Wi-Fi interface is still up, so I ran:

ifconfig interface down

(replace interface with yours of course).

After that the Wi-Fi interface seems to be able to go up fine.

4

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .