1

I just installed Debian7 on a laptop that I was using Windows on.

When on Windows I had wifi, and I want to set up the wifi on Debian.

On Ubuntu there is a nice feature in the panel where I can connect but only the wired one is showing up in Debian.

I can't seem to find any clear tutorial that works for me, and I really need wifi to work. Unfortunately a wired connection isn't an alternative option.

Any help is greatly appreciated!

[EDIT]

My output:

$ lspci -nn | grep 0280
03:00.0 Network Controller [0280] Intel Corporation Centrino Wireless-N 2230 [8086:0887] (rev c4)

$dmesg | grep -i wireless
[   7.861295] Intel(R) Wireless WiFi Link AGN driver for Linux, in tree:

$ sudo iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

$ sudo ifconfig
eth0      Link encap:Ethernet  HWaddr 10:bf:48:58:ec:d6  
          inet addr:139.165.112.68  Bcast:139.165.112.255  Mask:255.255.255.0
          inet6 addr: fe80::12bf:48ff:fe58:ecd6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:461221 errors:0 dropped:5828 overruns:0 frame:0
          TX packets:198287 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:491154704 (468.4 MiB)  TX bytes:17839931 (17.0 MiB)
          Interrupt:44 Base address:0xc000

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:584 errors:0 dropped:0 overruns:0 frame:0
          TX packets:584 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:44560 (43.5 KiB)  TX bytes:44560 (43.5 KiB)
  • Hi and welcome to SX. You should tell us what you have tried, and provide us with the model of your wifi device. The debian guide yo wifi is probably a good start to identify your device and install the basic required packages. – Vincent Nivoliers Apr 29 '15 at 8:52
  • THanks for the prompt reply!! so what I have tried, - Tried installing wicd, doesnt have anything in the wireless interface field when I go into preferences - Tried changing wpa_supplicant to no avail - Tried installing network-manager-gnome (and KDE though I am on GNOME) thought it was meant to give me a GUI but no, I need a GUI as I'm setting up for a friend – Eoin Apr 29 '15 at 8:54
  • These are tools to configure the connection, once the wifi device is recognized. You however need a driver or at least a firmware as well for the wifi device, which depends on the model. If you search the available packages using the keyword "firmware" you will see that there are plenty of them depending on your device. – Vincent Nivoliers Apr 29 '15 at 11:00
  • Ah got you!! nice one, the device is the one listed when I do "lspci"? Is it the one under either "Network controller" or "Ethernet controller" – Eoin Apr 29 '15 at 11:47
  • Follow the debian wiki instructions – Vincent Nivoliers Apr 29 '15 at 11:49
1

Since I found the fix I decided to post it as an answer.

What I did was go back and reinstall the operating system to see if there was anything I had missed and sure enough there was a point during the step where it detects the computers hardware that it requests some files (iwlwifi-2030-6.ucode, rtl_nic/rtl8168e-3.fw) for the Wireless card to work.

These files are located at the following links:

https://packages.debian.org/squeeze-backports/firmware-iwlwifi https://packages.debian.org/wheezy/firmware-realtek

All that I had to do was load them on to a USB stick and read them off the USB during the setup.

Thank you all again, for your help!

0

I believe you are missing the non-free firmware package. Given the wifi card you mention you should follow the corresponding debian documentation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.