0

I have installed xfonts-wqy in my newly installed Debian Jessie stable, by using the following command

 # aptitude search xfonts-wqy
 i  xfonts-wqy - WenQuanYi Bitmap Song CJK font for X

As you can see, the letter "i" before "xfonts-wqy - Wen..." tells us that the installation of xfonts-wqy is successful.

But when I list the font, there is nothing about WenQuanYi Bitmap Song, as you can see here:

[04/29/2015,10:49:53@~]$ fc-list |grep WenQuanYi
/usr/share/fonts/truetype/wqy/wqy-microhei.ttc: WenQuanYi Micro Hei,文泉驛微米黑,文泉驿微米黑:style=Regular
/usr/share/fonts/truetype/wqy/wqy-zenhei.ttc: WenQuanYi Zen Hei,文泉驛正黑,文泉驿正黑:style=Regular
/usr/share/fonts/truetype/wqy/wqy-zenhei.ttc: WenQuanYi Zen Hei Sharp,文泉驛點陣正黑,文泉驿点阵正黑:style=Regular
/usr/share/fonts/truetype/wqy/wqy-zenhei.ttc: WenQuanYi Zen Hei Mono,文泉驛等寬正黑,文泉驿等宽正黑:style=Regular
/usr/share/fonts/truetype/wqy/wqy-microhei.ttc: WenQuanYi Micro Hei Mono,文泉驛等寬微米黑,文泉驿等宽微米黑:style=Regular

So, my question is: Where is the font WenQuanYi Bitmap Song? And how can I use this font?

I also tried to reinstall xfonts-wqy several times, but the problem is still there.

Here is some information about my Debian Jessie:

[04/29/2015,10:46:36@~]$ uname -a
Linux debian 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt9-3~deb8u1 (2015-04-24) x86_64 GNU/Linux
[04/29/2015,10:54:06@~]$ mate-about -v
MATE Desktop Environment 1.8.1

Thanks a lot.

  • This won't help, but when I do the same on Debian 7.8, it works as expected. fc-list shows the .pcf fonts. So it's not you; maybe it's your system. Is there any setting that displays only outline fonts (i.e. ignoring bitmapped ones)? – Mr Lister Apr 29 '15 at 8:35
  • Actually before I upgrade to Debian Jessie, that is in Debian 7.8, all things went right. I could use WenQuanYi Bitmap Song. But when I upgrade to Debian several days ago, the problem occurs. – azc Apr 29 '15 at 8:50
0

The fonts are installed into /usr/share/fonts/X11/misc with filenames like wenquanyi_13px.pcf, but the question still remains as to why fc-list didn't find them there. When you installed xfonts-wqy, one of the things it should have said was Regenerating fonts cache... done. You can do this manually with more verbosity via the command fc-cache -vf and watch its output to see which directories it is checking. If it doesn't check X11, look into your fonts-conf files to make sure they haven't been changed (by you or a script) to make the directory search more specific---there should be something like <dir>/usr/share/fonts</dir> in one of the fonts-conf files (probably /etc/fonts/fonts.conf); if it only says /usr/share/fonts/truetype then that's the problem; in the worst case you might have to reset your fontconfig-config package and everything that depends on it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.