4

I have a computer with broken graphics here. It's running openSUSE 13.2 (x86_64). When a 3D application (paraview in this case) starts up it complains:

extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
ERROR: In /home/kitware/Dashboards/MyTests/NightlyMaster/ParaViewSuperbuild-Release/paraview/src/paraview/VTK/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx, line 382
vtkXOpenGLRenderWindow (0x3fe9c30): Could not find a decent visual

Xlib:  extension "GLX" missing on display ":0".
ERROR: In /home/kitware/Dashboards/MyTests/NightlyMaster/ParaViewSuperbuild-Release/paraview/src/paraview/VTK/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx, line 601
vtkXOpenGLRenderWindow (0x3fe9c30): GLX not found.  Aborting.


/users/uth/bin/Paraview: Zeile 2: 11291 Abgebrochen ~/Apps/ParaView-4.3.1-Linux-64bit/bin/paraview

[1]+  Exit 134                Paraview 

Here's /var/log/Xorg.0.log

[ 14428.155]
X.Org X Server 1.16.1
Release Date: 2014-09-21
[ 14428.155] X Protocol Version 11, Revision 0
[ 14428.155] Build Operating System: openSUSE SUSE LINUX
[ 14428.155] Current Operating System: Linux darcy 3.16.7-21-desktop #1 SMP PREEMPT Tue Apr 14 07:11:37 UTC 2015 (93c1539) x86_64
[ 14428.155] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.16.7-21-desktop root=UUID=6d6422e1-4468-4e89-abb8-3812a523f70f resume=/dev/sda3 splash=silent quiet showopts
[ 14428.155] Build Date: 04 March 2015  01:16:46PM
[ 14428.155]
[ 14428.155] Current version of pixman: 0.32.6
[ 14428.155]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[ 14428.155] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 14428.155] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Apr 28 16:56:26 2015
[ 14428.155] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 14428.155] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 14428.156] (==) No Layout section.  Using the first Screen section.
[ 14428.156] (==) No screen section available. Using defaults.
[ 14428.156] (**) |-->Screen "Default Screen Section" (0)
[ 14428.156] (**) |   |-->Monitor "<default monitor>"
[ 14428.156] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[ 14428.156] (==) Automatically adding devices
[ 14428.156] (==) Automatically enabling devices
[ 14428.156] (==) Automatically adding GPU devices
[ 14428.156] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
[ 14428.156]    Entry deleted from font path.
[ 14428.156] (==) FontPath set to:
        /usr/share/fonts/misc:unscaled,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi:unscaled,
        /usr/share/fonts/75dpi:unscaled,
        /usr/share/fonts/ghostscript/,
        /usr/share/fonts/cyrillic:unscaled,
        /usr/share/fonts/truetype/,
        built-ins
[ 14428.156] (==) ModulePath set to "/usr/lib64/xorg/modules"
[ 14428.156] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 14428.156] (II) Loader magic: 0x80ec60
[ 14428.156] (II) Module ABI versions:
[ 14428.156]    X.Org ANSI C Emulation: 0.4
[ 14428.156]    X.Org Video Driver: 18.0
[ 14428.156]    X.Org XInput driver : 21.0
[ 14428.156]    X.Org Server Extension : 8.0
[ 14428.156] (--) PCI:*(0:1:0:0) 10de:118e:1043:8477 rev 161, Mem @ 0xf6000000/16777216, 0xe8000000/134217728, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[ 14428.156] (II) LoadModule: "glx"
[ 14428.156] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 14428.162] (II) Module glx: vendor="NVIDIA Corporation"
[ 14428.162]    compiled for 4.0.2, module version = 1.0.0
[ 14428.162]    Module class: X.Org Server Extension
[ 14428.162] (II) NVIDIA GLX Module  340.76  Thu Jan 22 11:24:42 PST 2015
[ 14428.162] (==) Matched nvidia as autoconfigured driver 0
[ 14428.162] (==) Matched nouveau as autoconfigured driver 1
[ 14428.162] (==) Matched nv as autoconfigured driver 2
[ 14428.162] (==) Matched modesetting as autoconfigured driver 3
[ 14428.162] (==) Matched fbdev as autoconfigured driver 4
[ 14428.162] (==) Matched vesa as autoconfigured driver 5
[ 14428.162] (==) Assigned the driver to the xf86ConfigLayout
[ 14428.162] (II) LoadModule: "nvidia"
[ 14428.162] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 14428.162] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 14428.162]    compiled for 4.0.2, module version = 1.0.0
[ 14428.162]    Module class: X.Org Video Driver
[ 14428.162] (II) LoadModule: "nouveau"
[ 14428.162] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[ 14428.162] (II) Module nouveau: vendor="X.Org Foundation"
[ 14428.162]    compiled for 1.16.1, module version = 1.0.11
[ 14428.162]    Module class: X.Org Video Driver
[ 14428.162]    ABI class: X.Org Video Driver, version 18.0
[ 14428.162] (II) LoadModule: "nv"
[ 14428.162] (II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
[ 14428.163] (II) Module nv: vendor="X.Org Foundation"
[ 14428.163]    compiled for 1.16.1, module version = 2.1.20
[ 14428.163]    Module class: X.Org Video Driver
[ 14428.163]    ABI class: X.Org Video Driver, version 18.0
[ 14428.163] (II) LoadModule: "modesetting"
[ 14428.163] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[ 14428.163] (II) Module modesetting: vendor="X.Org Foundation"
[ 14428.163]    compiled for 1.16.1, module version = 0.9.0
[ 14428.163]    Module class: X.Org Video Driver
[ 14428.163]    ABI class: X.Org Video Driver, version 18.0
[ 14428.163] (II) LoadModule: "fbdev"
[ 14428.163] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 14428.163] (II) Module fbdev: vendor="X.Org Foundation"
[ 14428.163]    compiled for 1.16.1, module version = 0.4.4
[ 14428.163]    Module class: X.Org Video Driver
[ 14428.163]    ABI class: X.Org Video Driver, version 18.0
[ 14428.163] (II) LoadModule: "vesa"
[ 14428.163] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 14428.163] (II) Module vesa: vendor="X.Org Foundation"
[ 14428.163]    compiled for 1.16.1, module version = 2.3.3
[ 14428.163]    Module class: X.Org Video Driver
[ 14428.163]    ABI class: X.Org Video Driver, version 18.0
[ 14428.163] (II) NVIDIA dlloader X Driver  340.76  Thu Jan 22 11:03:05 PST 2015
[ 14428.163] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 14428.163] (II) NOUVEAU driver 
[ 14428.163] (II) NOUVEAU driver for NVIDIA chipset families :
[ 14428.163]    RIVA TNT        (NV04)
[ 14428.163]    RIVA TNT2       (NV05)
[ 14428.163]    GeForce 256     (NV10)
[ 14428.163]    GeForce 2       (NV11, NV15)
[ 14428.163]    GeForce 4MX     (NV17, NV18)
[ 14428.163]    GeForce 3       (NV20)
[ 14428.163]    GeForce 4Ti     (NV25, NV28)
[ 14428.163]    GeForce FX      (NV3x)
[ 14428.163]    GeForce 6       (NV4x)
[ 14428.163]    GeForce 7       (G7x)
[ 14428.163]    GeForce 8       (G8x)
[ 14428.163]    GeForce GTX 200 (NVA0)
[ 14428.163]    GeForce GTX 400 (NVC0)
[ 14428.163] (II) NOUVEAU driver 
[ 14428.163] (II) NOUVEAU driver for NVIDIA chipset families :
[ 14428.163]    RIVA TNT        (NV04)
[ 14428.163]    RIVA TNT2       (NV05)
[ 14428.163]    GeForce 256     (NV10)
[ 14428.163]    GeForce 2       (NV11, NV15)
[ 14428.163]    GeForce 4MX     (NV17, NV18)
[ 14428.163]    GeForce 3       (NV20)
[ 14428.163]    GeForce 4Ti     (NV25, NV28)
[ 14428.163]    GeForce FX      (NV3x)
[ 14428.163]    GeForce 6       (NV4x)
[ 14428.163]    GeForce 7       (G7x)
[ 14428.163]    GeForce 8       (G8x)
[ 14428.163]    GeForce GTX 200 (NVA0)
[ 14428.163]    GeForce GTX 400 (NVC0)
[ 14428.163] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 14428.163] (II) FBDEV: driver for framebuffer: fbdev
[ 14428.163] (II) VESA: driver for VESA chipsets: vesa
[ 14428.163] (++) using VT number 7

[ 14428.163] (II) Loading sub module "fb"
[ 14428.163] (II) LoadModule: "fb"
[ 14428.163] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 14428.163] (II) Module fb: vendor="X.Org Foundation"
[ 14428.163]    compiled for 1.16.1, module version = 1.0.0
[ 14428.163]    ABI class: X.Org ANSI C Emulation, version 0.4
[ 14428.163] (WW) Unresolved symbol: fbGetGCPrivateKey
[ 14428.163] (II) Loading sub module "wfb"
[ 14428.163] (II) LoadModule: "wfb"
[ 14428.163] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[ 14428.163] (II) Module wfb: vendor="X.Org Foundation"
[ 14428.163]    compiled for 1.16.1, module version = 1.0.0
[ 14428.163]    ABI class: X.Org ANSI C Emulation, version 0.4
[ 14428.163] (II) Loading sub module "ramdac"
[ 14428.163] (II) LoadModule: "ramdac"
[ 14428.163] (II) Module "ramdac" already built-in
[ 14428.185] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[ 14428.185] (EE) NVIDIA:     system's kernel log for additional error messages and
[ 14428.185] (EE) NVIDIA:     consult the NVIDIA README for details.
[ 14428.185] (EE) [drm] KMS not enabled
[ 14428.185] (EE) [drm] KMS not enabled
[ 14428.185] (EE) open /dev/dri/card0: No such file or directory
[ 14428.185] (WW) Falling back to old probe method for modesetting
[ 14428.185] (EE) open /dev/dri/card0: No such file or directory
[ 14428.185] (II) Loading sub module "fbdevhw"
[ 14428.185] (II) LoadModule: "fbdevhw"
[ 14428.185] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 14428.185] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 14428.185]    compiled for 1.16.1, module version = 0.0.2
[ 14428.185]    ABI class: X.Org Video Driver, version 18.0
[ 14428.185] (**) FBDEV(1): claimed PCI slot 1@0:0:0
[ 14428.185] (II) FBDEV(1): using default device
[ 14428.185] (WW) Falling back to old probe method for vesa
[ 14428.185] (EE) Screen 0 deleted because of no matching config section.
[ 14428.185] (II) UnloadModule: "modesetting"
[ 14428.185] (II) FBDEV(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[ 14428.185] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
[ 14428.185] (==) FBDEV(0): RGB weight 888
[ 14428.185] (==) FBDEV(0): Default visual is TrueColor
[ 14428.185] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
[ 14428.185] (II) FBDEV(0): hardware: VESA VGA (video memory: 9216kB)
[ 14428.185] (II) FBDEV(0): checking modes against framebuffer device...
[ 14428.185] (II) FBDEV(0): checking modes against monitor...
[ 14428.185] (--) FBDEV(0): Virtual size is 2048x1152 (pitch 2048)
[ 14428.185] (**) FBDEV(0):  Built-in mode "current": 236.0 MHz, 113.5 kHz, 96.5 Hz
[ 14428.185] (II) FBDEV(0): Modeline "current"x0.0  236.02  2048 2080 2080 2080  1152 1156 1160 1176 -hsync -vsync -csync (113.5 kHz b)
[ 14428.185] (==) FBDEV(0): DPI set to (96, 96)
[ 14428.185] (II) Loading sub module "fb"
[ 14428.185] (II) LoadModule: "fb"
[ 14428.185] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 14428.185] (II) Module fb: vendor="X.Org Foundation"
[ 14428.185]    compiled for 1.16.1, module version = 1.0.0
[ 14428.185]    ABI class: X.Org ANSI C Emulation, version 0.4
[ 14428.185] (**) FBDEV(0): using shadow framebuffer
[ 14428.185] (II) Loading sub module "shadow"
[ 14428.185] (II) LoadModule: "shadow"
[ 14428.185] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[ 14428.185] (II) Module shadow: vendor="X.Org Foundation"
[ 14428.185]    compiled for 1.16.1, module version = 1.1.0
[ 14428.185]    ABI class: X.Org ANSI C Emulation, version 0.4
[ 14428.185] (II) UnloadModule: "vesa"
[ 14428.185] (II) Unloading vesa
[ 14428.185] (==) Depth 24 pixmap format is 32 bpp
[ 14428.185] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
[ 14428.185] (==) FBDEV(0): Backing store enabled
[ 14428.185] (==) FBDEV(0): DPMS enabled
[ 14428.185] (==) RandR enabled
[ 14428.188] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
[ 14428.210] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[ 14428.210] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 14428.210] (**) Power Button: Applying InputClass "system-keyboard"
[ 14428.210] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 14428.210] (II) LoadModule: "evdev"
[ 14428.210] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 14428.210] (II) Module evdev: vendor="X.Org Foundation"
[ 14428.210]    compiled for 1.16.1, module version = 2.9.0
[ 14428.210]    Module class: X.Org XInput Driver
[ 14428.210]    ABI class: X.Org XInput driver, version 21.0
[ 14428.210] (II) Using input driver 'evdev' for 'Power Button'
[ 14428.210] (**) Power Button: always reports core events
[ 14428.210] (**) evdev: Power Button: Device: "/dev/input/event1"
[ 14428.211] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 14428.211] (--) evdev: Power Button: Found keys
[ 14428.211] (II) evdev: Power Button: Configuring as keyboard
[ 14428.211] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input4/event1"
[ 14428.211] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[ 14428.211] (**) Option "xkb_rules" "evdev"
[ 14428.211] (**) Option "xkb_model" "pc105"
[ 14428.211] (**) Option "xkb_layout" "de"
[ 14428.211] (**) Option "xkb_variant" "nodeadkeys"
[ 14428.211] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 14428.220] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[ 14428.220] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 14428.220] (**) Power Button: Applying InputClass "system-keyboard"
[ 14428.220] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 14428.220] (II) Using input driver 'evdev' for 'Power Button'
[ 14428.220] (**) Power Button: always reports core events
[ 14428.220] (**) evdev: Power Button: Device: "/dev/input/event0"
[ 14428.221] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 14428.221] (--) evdev: Power Button: Found keys
[ 14428.221] (II) evdev: Power Button: Configuring as keyboard
[ 14428.221] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input3/event0"
[ 14428.221] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[ 14428.221] (**) Option "xkb_rules" "evdev"
[ 14428.221] (**) Option "xkb_model" "pc105"
[ 14428.221] (**) Option "xkb_layout" "de"
[ 14428.221] (**) Option "xkb_variant" "nodeadkeys"
[ 14428.221] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 14428.221] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event14)
[ 14428.221] (II) No input driver specified, ignoring this device.
[ 14428.221] (II) This device may have been added with another device file.
[ 14428.221] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event15)
[ 14428.221] (II) No input driver specified, ignoring this device.
[ 14428.221] (II) This device may have been added with another device file.
[ 14428.221] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event16)
[ 14428.221] (II) No input driver specified, ignoring this device.
[ 14428.221] (II) This device may have been added with another device file.
[ 14428.221] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=9 (/dev/input/event17)
[ 14428.221] (II) No input driver specified, ignoring this device.
[ 14428.221] (II) This device may have been added with another device file.
[ 14428.221] (II) config/udev: Adding input device DELL Dell QuietKey Keyboard (/dev/input/event2)
[ 14428.221] (**) DELL Dell QuietKey Keyboard: Applying InputClass "evdev keyboard catchall"
[ 14428.221] (**) DELL Dell QuietKey Keyboard: Applying InputClass "system-keyboard"
[ 14428.221] (**) DELL Dell QuietKey Keyboard: Applying InputClass "evdev keyboard catchall"
[ 14428.221] (II) Using input driver 'evdev' for 'DELL Dell QuietKey Keyboard'
[ 14428.221] (**) DELL Dell QuietKey Keyboard: always reports core events
[ 14428.221] (**) evdev: DELL Dell QuietKey Keyboard: Device: "/dev/input/event2"
[ 14428.221] (--) evdev: DELL Dell QuietKey Keyboard: Vendor 0x413c Product 0x2106
[ 14428.221] (--) evdev: DELL Dell QuietKey Keyboard: Found keys
[ 14428.221] (II) evdev: DELL Dell QuietKey Keyboard: Configuring as keyboard
[ 14428.221] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3:1.0/0003:413C:2106.0001/input/input5/event2"
[ 14428.221] (II) XINPUT: Adding extended input device "DELL Dell QuietKey Keyboard" (type: KEYBOARD, id 8)
[ 14428.221] (**) Option "xkb_rules" "evdev"
[ 14428.221] (**) Option "xkb_model" "pc105"
[ 14428.221] (**) Option "xkb_layout" "de"
[ 14428.221] (**) Option "xkb_variant" "nodeadkeys"
[ 14428.221] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 14428.221] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/event3)
[ 14428.221] (**) Logitech USB-PS/2 Optical Mouse: Applying InputClass "evdev pointer catchall"
[ 14428.221] (**) Logitech USB-PS/2 Optical Mouse: Applying InputClass "evdev pointer catchall"
[ 14428.221] (II) Using input driver 'evdev' for 'Logitech USB-PS/2 Optical Mouse'
[ 14428.222] (**) Logitech USB-PS/2 Optical Mouse: always reports core events
[ 14428.222] (**) evdev: Logitech USB-PS/2 Optical Mouse: Device: "/dev/input/event3"
[ 14428.222] (--) evdev: Logitech USB-PS/2 Optical Mouse: Vendor 0x46d Product 0xc050
[ 14428.222] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found 12 mouse buttons
[ 14428.222] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found scroll wheel(s)
[ 14428.222] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found relative axes
[ 14428.222] (--) evdev: Logitech USB-PS/2 Optical Mouse: Found x and y relative axes
[ 14428.222] (II) evdev: Logitech USB-PS/2 Optical Mouse: Configuring as mouse
[ 14428.222] (II) evdev: Logitech USB-PS/2 Optical Mouse: Adding scrollwheel support
[ 14428.222] (**) evdev: Logitech USB-PS/2 Optical Mouse: YAxisMapping: buttons 4 and 5
[ 14428.222] (**) evdev: Logitech USB-PS/2 Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 14428.222] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4:1.0/0003:046D:C050.0002/input/input6/event3"
[ 14428.222] (II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse" (type: MOUSE, id 9)
[ 14428.222] (II) evdev: Logitech USB-PS/2 Optical Mouse: initialized for relative axes.
[ 14428.222] (**) Logitech USB-PS/2 Optical Mouse: (accel) keeping acceleration scheme 1
[ 14428.222] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration profile 0
[ 14428.222] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration factor: 2.000
[ 14428.222] (**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration threshold: 4
[ 14428.222] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/mouse0)
[ 14428.222] (II) No input driver specified, ignoring this device.
[ 14428.222] (II) This device may have been added with another device file.
[ 14428.222] (II) config/udev: Adding input device HDA Intel PCH Rear Mic (/dev/input/event7)
[ 14428.222] (II) No input driver specified, ignoring this device.
[ 14428.222] (II) This device may have been added with another device file.
[ 14428.222] (II) config/udev: Adding input device HDA Intel PCH Line (/dev/input/event8)
[ 14428.222] (II) No input driver specified, ignoring this device.
[ 14428.222] (II) This device may have been added with another device file.
[ 14428.222] (II) config/udev: Adding input device HDA Intel PCH Line Out Front (/dev/input/event9)
[ 14428.222] (II) No input driver specified, ignoring this device.
[ 14428.222] (II) This device may have been added with another device file.
[ 14428.222] (II) config/udev: Adding input device HDA Intel PCH Line Out Surround (/dev/input/event10)
[ 14428.222] (II) No input driver specified, ignoring this device.
[ 14428.222] (II) This device may have been added with another device file.
[ 14428.222] (II) config/udev: Adding input device HDA Intel PCH Line Out CLFE (/dev/input/event11)
[ 14428.222] (II) No input driver specified, ignoring this device.
[ 14428.222] (II) This device may have been added with another device file.
[ 14428.222] (II) config/udev: Adding input device HDA Intel PCH Line Out Side (/dev/input/event12)
[ 14428.222] (II) No input driver specified, ignoring this device.
[ 14428.222] (II) This device may have been added with another device file.
[ 14428.222] (II) config/udev: Adding input device HDA Intel PCH Front Headphone (/dev/input/event13)
[ 14428.222] (II) No input driver specified, ignoring this device.
[ 14428.222] (II) This device may have been added with another device file.
[ 14428.223] (II) config/udev: Adding input device HDA Intel PCH Front Mic (/dev/input/event6)
[ 14428.223] (II) No input driver specified, ignoring this device.
[ 14428.223] (II) This device may have been added with another device file.
[ 14428.223] (II) config/udev: Adding input device Eee PC WMI hotkeys (/dev/input/event4)
[ 14428.223] (**) Eee PC WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[ 14428.223] (**) Eee PC WMI hotkeys: Applying InputClass "system-keyboard"
[ 14428.223] (**) Eee PC WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[ 14428.223] (II) Using input driver 'evdev' for 'Eee PC WMI hotkeys'
[ 14428.223] (**) Eee PC WMI hotkeys: always reports core events
[ 14428.223] (**) evdev: Eee PC WMI hotkeys: Device: "/dev/input/event4"
[ 14428.223] (--) evdev: Eee PC WMI hotkeys: Vendor 0 Product 0
[ 14428.223] (--) evdev: Eee PC WMI hotkeys: Found keys
[ 14428.223] (II) evdev: Eee PC WMI hotkeys: Configuring as keyboard
[ 14428.223] (**) Option "config_info" "udev:/sys/devices/platform/eeepc-wmi/input/input7/event4"
[ 14428.223] (II) XINPUT: Adding extended input device "Eee PC WMI hotkeys" (type: KEYBOARD, id 10)
[ 14428.223] (**) Option "xkb_rules" "evdev"
[ 14428.223] (**) Option "xkb_model" "pc105"
[ 14428.223] (**) Option "xkb_layout" "de"
[ 14428.223] (**) Option "xkb_variant" "nodeadkeys"
[ 14428.223] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[ 14428.223] (II) config/udev: Adding input device PC Speaker (/dev/input/event5)
[ 14428.223] (II) No input driver specified, ignoring this device.
[ 14428.223] (II) This device may have been added with another device file.
[ 14428.225] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
[ 15028.380] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
[ 15028.380] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
[ 15028.382] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)

dmesg | grep -i nvidia:

[   10.503609] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input17
[   10.503692] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input18
[   10.503789] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input19
[   10.503881] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input20

installed packages as per zypper se nvidia: nvidia-computeG03, nvidia-gfxG03-kmp-desktop, nvidia-glG03, nvidia-uvm-gfxG03-kmp-desktop, x11-video-nvidiaG03

lspci | grep -i nvidia:

01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 760 OEM] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK104 HDMI Audio Controller (rev a1)

The computer also has a second monitor attached, which is blank. I don't know if some update caused this.

I'd include more info but the character count is limited, so please tell me what else you need to see, and what parts I can delete without making the question useless.

What might be the cause of this and how can I fix it?

7
  • 1
    NVIDIA: Failed to initialize the NVIDIA kernel module. looks like the relevant error; does dmesg give anything? What about sudo modprobe nvidia (or sudo modprobe nvidia-current)? – derobert Apr 28 '15 at 15:47
  • dmesg | grep nvidia gives nothing, should I filter differently? modprobe commands give FATAL: Module nvidia_uvm not found. and FATAL: Module nvidia-current not found., respectively – Christoph Apr 28 '15 at 15:53
  • well, grep -i nvidia. But it sounds like you're missing half of your nvidia kernel modules. Maybe check that all the relevant packages are installed? – derobert Apr 28 '15 at 15:55
  • added those to the quesion – Christoph Apr 28 '15 at 16:00
  • Thank you. It appears you've now got enough info in the question for someone with openSUSE knowledge to tell you how to fix it—personally I'd guess reinstalling that uvm package might work, but I don't know openSUSE so you might want to wait. – derobert Apr 28 '15 at 16:03
1

To solve this you should use the official Drivers from Nvidia and from the OpenSuSE's Nvidia repo.

The easiest way is to go to this link and select the "GeForce 6 and GeForce 7". You are selecting GeForce 6 because of the output of lspci

Installing multiple Nvidia drivers can cause issues (I know from personal experience) so if the YUP suggests removing other drivers, go ahead and let YaST do that.

Once the install is completed, reboot, and you should see a new application installed called Nvidia Settings or something similar and that will allow you to work with your additional monitor.

2
  • I know that U&L.SE discourages posting links as answers; however, since this is a driver issue I feel that the best I can do is direct to the location and give general tips. – SailorCire May 8 '15 at 18:58
  • I am not even sure should I downvote it or not. What makes you think that the problem disappear with binary drivers; also the interesting part of the question is what's wrong is here — even if FOSS drivers could be slower, but at least these should work. In the question these just doesn't. – Hi-Angel Sep 11 '15 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.