0

I used this command to install Nagios::Plugins on multiple servers months/weeks before:

perl -MCPAN -e 'install Nagios::Plugin'

Now I get this error message:

Reading '/root/.cpan/Metadata'
Database was generated on Mon, 27 Apr 2015 00:29:02 GMT
Warning: Cannot install Nagios::Plugin, don't know what it is.

As far as I can tell, the module is still in CPAN: http://search.cpan.org/dist/Nagios-Plugin/

What´s wrong?

7

Nagios::Plugins was renamed to Monitoring::Plugins due to trademark reason. cpan doesn't index Nagios::Plugins anymore. Now you must install Monitoring::Plugin

perl -MCPAN -e 'install Monitoring::Plugin'

Or you can install it via cpanm. First install cpanm:

curl -L http://cpanmin.us | perl - --sudo App::cpanminus

and then install the module

cpanm Monitoring::Plugin

Further reading

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.