Long story short, I need a dualboot win7/FC21 laptop. Fedora 21 would replace the existing Ubuntu install (so I am pretty sure this is already a non uefi box). BIOS does not mention UEFI anywhere I can see.

All the sticks I have been able to create this far (using unetbootin and liveusb-creator, currently trying multibootusb; ISO is Fedora-Live-MATE_Compiz-x86_64-21-5.iso) have given me a uefi-booting image - after which, upon install-to-disk, anaconda insists on wanting a UEFI partition.

I could try making a DVD but I am wondering if the ISO itself may be the cause. The Fedora site goes on and on about BIOS UEFI-related switches, but as I said this machine has none.


EDIT: re-creating the stick with dd also results in a UEFI live. So it looks like the ISOs (tried regular desktop spin this time) are at fault. What now?

2 Answers 2


So it appears it wasn't the ISO, after all. At some point I noticed that the USB stick had a GPT partition table on it. So, following the instructions at https://fedoraproject.org/wiki/How_to_create_and_use_Live_USB#litd

I reset it by:

 #livecd-iso-to-disk  --format --reset-mbr --overlay-size-mb 1024 /home/alf/Fedora-Live-MATE_Compiz-x86_64-21-5.iso /dev/sd

Which gave me a non-uefi stick. Wish I could say easy and intuitive - it ain't.

  • Good that you figured it out. As an aside, Fedora 21 has been EOL.
    – Sokel
    Commented Jan 24, 2016 at 19:11

This worked for me, too. Thank you "Alien Life Form".

Here, I install Fedora.iso into a USB stick that is identified by /dev/sdb. For completeness (but not shown), I deleted all partitions on that USB stick, just in case.

root@linux# dnf install livecd-tools

root@linux# livecd-iso-to-disk --format --reset-mbr --overlay-size-mb 1024 /home/user/Download/Fedora.iso /dev/sdb

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .