I have some database dumps from a Windows system on my box. They are text files. I'm using cygwin to grep through them. These appear to be plain text files; I open them with text editors such as notepad and wordpad and they look legible. However, when I run grep on them, it will say binary file foo.txt matches.

I have noticed that the files contain some ascii NUL characters, which I believe are artifacts from the database dump.

So what makes grep consider these files to be binary? The NUL character? Is there a flag on the filesystem? What do I need to change to get grep to show me the line matches?

  • 4
    --null-data may be useful if NUL is the delimiter.
    – Steve-o
    Commented Sep 1, 2011 at 13:27

10 Answers 10


If there is a NUL character anywhere in the file, grep will consider it as a binary file.

There might a workaround like this cat file | tr -d '\000' | yourgrep to eliminate all null first, and then to search through file.

  • 189
    ... or use -a/--text, at least with GNU grep.
    – derobert
    Commented Nov 26, 2012 at 20:44
  • 6
    Is the presence of a NUL character the only criteria? I doubt it. It's probably smarter than that. Anything falling outside the Ascii 32-126 range would be my guess, but we'd have to look at the source code to be sure. Commented Aug 14, 2015 at 16:58
  • 3
    My info was from the man page of the specific grep instance. Your comment about implementation is valid, source trumps docs.
    – bbaja42
    Commented Aug 18, 2015 at 22:31
  • 3
    I had a file which grep on cygwin considered binary because it had a long dash (0x96) instead of a regular ASCII hyphen/minus (0x2d). I guess this answer resolved the OP's issue, but it appears it is incomplete.
    – cp.engr
    Commented Feb 15, 2016 at 16:15
  • 2
    BSD grep (which is available on MacOS) also supports -a / --text Commented Oct 30, 2018 at 15:21

grep -a worked for me:

$ grep --help
 -a, --text                equivalent to --binary-files=text
  • 9
    This is the best, least expensive answer IMO.
    – pydsigner
    Commented Sep 24, 2016 at 18:32
  • 2
    But not POSIX compliant
    – Matteo
    Commented Aug 9, 2019 at 8:08
  • 2
    Would you mind to explain why it is not? It would be good to make it clear, for all of us who find this answer as an option. Thanks :).
    – ivanleoncz
    Commented Nov 4, 2019 at 19:36
  • 1
    Hey I've come here a SECOND time to relearn this LOL. A French accent (diacritic) in the text was causing grep to barf
    – zzapper
    Commented Oct 26, 2020 at 9:43

You can use the strings utility to extract the text content from any file and then pipe it through grep, like this: strings file | grep pattern.

  • 4
    Ideal for grepping log files that might be partly corrupted
    – Hannes R.
    Commented Feb 27, 2015 at 7:43
  • 2
    yes, sometimes binary mixed logging also happens. This is good.
    – user80158
    Commented Sep 3, 2017 at 16:59
  • This will work with any UTF-8 file, or something like --encoding option should be specified? -e S seems insufficient
    – Pablo A
    Commented Nov 17, 2022 at 20:16

GNU grep 2.24 RTFS

Conclusion: 2 and 2 cases only:

  • NUL, e.g. printf 'a\0' | grep 'a'

  • encoding error according to the C99 mbrlen(), e.g.:

    export LC_CTYPE='en_US.UTF-8'
    printf 'a\x80' | grep 'a'

    because \x80 cannot be the first byte of an UTF-8 Unicode point: UTF-8 - Description | en.wikipedia.org

Those checks are only done up to the Nth byte of the input, where N = TODO (32KiB in one test system). If the check would fail after the Nth byte, the file is still considered a text file. (mentioned by Stéphane Chazelas).

Only up to the first buffer read

So if a NUL or encoding error happens in the middle of a very large file, it might be grepped anyways.

I imagine this is for performance reasons.

E.g.: this prints the line:

printf '%10000000s\n\x80a' | grep 'a'

but this does not:

printf '%10s\n\x80a' | grep 'a'

The actual buffer size depends on how the file is read. E.g. compare:

export LC_CTYPE='en_US.UTF-8'
(printf '\n\x80a') | grep 'a'
(printf '\n'; sleep 1; printf '\x80a') | grep 'a'

With the sleep, the first line gets passed to grep even if it is only 1 byte long because the process goes to sleep, and the second read does not check if the file is binary.


git clone git://git.savannah.gnu.org/grep.git 
cd grep
git checkout v2.24

Find where the stderr error message is encoded:

git grep 'Binary file'

Leads us to src/grep.c:

if (!out_quiet && (encoding_error_output
                   || (0 <= nlines_first_null && nlines_first_null < nlines)))
    printf (_("Binary file %s matches\n"), filename);

If those variables were well named, we basically reached the conclusion.


Quick grepping for encoding_error_output shows that the only code path that can modify it goes through buf_has_encoding_errors:

clen = mbrlen (p, buf + size - p, &mbs);
if ((size_t) -2 <= clen)
  return true;

then just man mbrlen.

nlines_first_null and nlines

Initialized as:

intmax_t nlines_first_null = -1;
/* removed for brevity */
nlines = 0;

so when a null is found 0 <= nlines_first_null becomes true.

TODO when can nlines_first_null < nlines ever be false? I got lazy.


Does not define binary options for grep, and GNU grep does not document it, so RTFS is the only way.

  • 1
    Impressive explication!
    – user394
    Commented Apr 13, 2016 at 2:02
  • 2
    Note that the check for valid UTF-8 only happens in UTF-8 locales. Also note that the check is only done on the first buffer read from the file which for a regular file seems to be 32768 bytes on my system, but for a pipe or socket can be as small as one byte. Compare (printf '\n\0y') | grep y with (printf '\n'; sleep 1; printf '\0y') | grep y for instance. Commented Apr 13, 2016 at 12:18
  • 1
    I didn't look into great detail either, but did very recently Commented Apr 13, 2016 at 13:09
  • 2
    Dammit, the only answer that thoroughly and precisely addresses the questions is sits down here with 10% of the votes of the most voted one.
    – Quasímodo
    Commented Mar 3, 2021 at 20:20
  • 2
    @Quasímodo cirosantilli.com/… Commented Mar 4, 2021 at 6:33

One of my text files was suddenly being seen as binary by grep:

$ file foo.txt
foo.txt: ISO-8859 text

Solution was to convert it by using iconv:

iconv -t UTF-8 -f ISO-8859-1 foo.txt > foo_new.txt
  • 1
    This happened to me as well. In particular, the cause was an ISO-8859-1-encoded non-breaking space, which I had to replace with a regular space in order to get grep to search in the file.
    – Gallaecio
    Commented Jun 9, 2015 at 13:50
  • 4
    grep 2.21 treats ISO-8859 text files as if they are binary, add export LC_ALL=C before grep command.
    – netawater
    Commented Aug 17, 2015 at 2:52
  • @netawater Thanks! This is e.g. the case if you have something like Müller in a text-file. That's 0xFC hexadecimal, so outside the range grep would expect for utf8 (up to 0x7F). Check with printf 'a\x7F' | grep 'a' as Ciro describe above. Commented Nov 26, 2016 at 16:51

The file /etc/magic or /usr/share/misc/magic has a list of sequences that the command file uses for determining the file type.

Note that binary may just be a fallback solution. Sometimes files with strange encoding are considered binary too.

grep on Linux has some options to handle binary files like --binary-files or -U / --binary


One of my students had this problem. There is a bug in grep in Cygwin. If the file has non-Ascii characters, grep and egrep see it as binary.

  • That sounds like a feature, not a bug. Especially given there is a command-line option to control it (-a / --text) Commented Jan 29, 2018 at 11:39

Actually answering the question "What makes grep consider a file to be binary?", you can use iconv:

$ iconv < myfile.java
iconv: (stdin):267:70: cannot convert

In my case there were Spanish characters that showed up correctly in text editors but grep considered them as binary; iconv output pointed me to the line and column numbers of those characters

In the case of NUL characters, iconv will consider them normal and will not print that kind of output so this method is not suitable


I had the same problem. I used vi -b [filename] to see the added characters. I found the control characters ^@ and ^M. Then in vi type :1,$s/^@//g to remove the ^@ characters. Repeat this command for ^M.

Warning: To get the "blue" control characters press Ctrl+v then Ctrl+M or Ctrl+@. Then save and exit vi.


I also had this problem but in my case it was caused when a matched line is too long.

file myfile.txt
myfile.txt: UTF-8 Unicode text, with very long lines

grep would run through the entire file fine with many patterns but when a pattern matched a "very long line" it stopped with Binary file myfile.txt matches.

Adding -a also solves this problem but pre-parsing the file for NULL or other invalid chars would have no effect (there are none otherwise grep would not complete for other patterns). In this case the offending line had 25k+ characters!

What I don't understand is why it only happens when grep tries to return the line and not when it is processing it looking for other patterns.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .