0

I've already uninstalled my Windows and installed Elementary Freya OS. But then my laptop won't reboot. It said "Reboot and select proper boot device ..."

Here is the complete specification of my laptop : complete specifications

Did this happen because I haven't turned off my EFI mode via the Windows 8 setting before I removed the Windows OS? If it was so, then how can I set it off directly from the BIOS?

** my laptop type is asus a450c

  • My guess is that you didn’t write a bootloader, or it didn’t write correctly. (I’ve been in both of those situations many times.) Can you boot to your installed OS with a boot disk? – yellowantphil Apr 28 '15 at 5:34
  • @yellowantphil i'm not sure how can i write a bootloader. do you mind to tell me how can i do that? I installed my OS with a usb stick. – everlasting-learner Apr 28 '15 at 6:20
  • Check your OS documentation to see if it says anything about installing GRUB. You might be able to boot into your OS using the install discs too. There could be a “boot to existing OS” option. – yellowantphil Apr 28 '15 at 13:42
0

Here are things that I've tried to install Elementary OS Freya on a UEFI PC/laptop.

  1. I tried to find the UEFI setting in the BIOS mode after I've done installing the eOS, but I can't find any setting on this asus. - failed.
  2. I created partitions for /boot and / separately and try to installed the eOS again, but yet it's still failed.
  3. The last try, I realized that in the installation process, eOS was asking me to add a /efi partition which will add some setting in those /efi partition. I tried it, but without internet connection,the installation process crash in the middle of it.
  4. I reinstalled once again, creating /efi, /, /home and swap partitions and also turning on my internet connection and it works!
0

It looks as though you've more or less answered your own question (which is great). For future reference (and the benefit of others who might look at this question), in regard to step 1 in your second post, you can enable changing the UEFI settings in BIOS by creating a UEFI password. Seems a bit odd, but it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.