3

Have been trying to fix it in various ways, but all these advices on the internet turned out useless for me. It was too strange to see when one instruction help other people, but don't solve my problem.

When I mark the package in Synaptic Package Manager and press "Apply", it says:

Could not apply changes!
Fix broken packages first.

Then i click Synaptic --> Edit --> Fix Broken Packages and i get this:

An error occurred
The following details are provided:

E: Unable to correct problems, you have held broken packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

Is there any way to fix this issue?

2

Same issue here when trying to build Barrier on Debian... Installing libcurl3-nss (by itself), followed by libcurl4-nss-dev gave me a successful build.

(Already had libcurl3 and libcurl3-gnutls installed)

1

Here it is! I had a lot of sources, but after adding the following ones, the problem disappeared:

deb http://ftp.ua.debian.org/debian jessie main # contrib non-free # 
#deb-src http://ftp.ua.debian.org/debian jessie main # contrib non-free # 
deb http://ftp.ua.debian.org/debian jessie-updates main # contrib non-free #
#deb-src http://ftp.ua.debian.org/debian jessie-updates main # contrib non-free #

Can't tell you why exactly these, but it works. Synaptic isn't capricious any more.

If you have any explanation or simply have something to say about this issue, tell it, please! It may be very useful.

0

In Mint 17.3 (KDE64), I ended up going to the settings menu and selected repositories. Trying many of the options since 'Fix broken packages' did not work as such. I used the restore default settings option. After which the system automatically had performed an update. Once completed it worked..somehow (I'm sure that I had installed something or changed things on my own without knowing or paying attention). Now unless you have SPECIFIC SETTINGS put into place I advise using caution maybe write down or take screenshots of your current setting before using the defaults option. Good Luck and again use caution.

  • 1
    Good notice! Indeed. – yulian Mar 4 '18 at 10:13
0

You can also try this:

  • rm /var/lib/apt/lists/lock
  • rm /var/cache/apt/archives/lock
  • rm /var/lib/dpkg/lock

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.