1

In this answer, the password prompt for gpg-agent includes options for how long the password should be remembered.

neirbowj's pinentry

However, in my system I get a much simpler prompt, without that option

my pinentry

How can I get a the more full featured password prompt? I think it might have to do with changing the pinentry program gpg-agent uses from pinentry-gtk-2 to something else. What alternative program can I use instead of pinentry-gtk here?

  • You can configure the cache time in ~/.gnupg/gpg-agent.conf, see man gpg-agent | less -p cache for the options.... – jasonwryan Apr 26 '15 at 19:11
  • I was thinking more about changing pinentry-program. Do you know whats the one that shows up in the first picture? – hugomg Apr 26 '15 at 20:15
  • It looks like a Gnome thing... – jasonwryan Apr 26 '15 at 20:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.