I have a "stubborn" file on an NTFS partition which refuses to be deleted.

A little background on the problem...

Problem happened when I was running Zim on my Linux and the system froze due to some reason. Now, Zim had a page open at that time which was being edited. Zim is a notebook wiki which stores its data in plain text files. Each page of zim is stored in a text file. Hence there was some file which was open at that time on the filesystem.

I rebooted using the power switch, and when I opened Zim and tried editing the page it was unable to save that page and instead created a backup file for that page by the name myNote.txt.zim-new~. Now, when I try to delete this file, it says:

rm: cannot remove ‘myNote.txt.zim-new~’: No such file or directory

My hunch is that Zim moved the original file being edited to this backup file and created a new file. So, this backup file is the original which got corrupt.

The thing is that I can read this file perfectly fine, but renaming it or deleting it or even moving to trash is not working. I also tried deleting with root.

So far after researching a bit, I found that it might have got something to do with the special character in the name of this file. Or maybe the file has just got corrupted in some weird way. And the solutions people are suggesting is using chkdsk in Windows.

But the problem is that I don't have Windows. So, how are people fixing such errors?


I tried using ntfsfix and testdisk but they reported the partition to be okay.


I created a new file with very similar name and it gets deleted/renamed/moved to trash very easily.


That folder is synchronized with Dropbox, if that's any help.

PS: I have an ntfs partition on a Linux-only box because I was thinking of installing Windows later. And this partition would act as the common for both.

  • Why are you using NTFS on a system that doesn't dual-boot to Windows? NTFS does have some features not available in "native" filesystems for Unix/Linux type OSes, but the reverse is also true. On balance, these other filesystems will work better. Apr 27, 2015 at 2:14
  • ^ reason for this is written in my question's post script.
    – shivams
    Apr 27, 2015 at 5:29
  • Too bad you don't have a Windows 10 computer handy. If you did, the fix would be easy. Mar 1, 2020 at 23:36

1 Answer 1


NTFS is not a "native" filesystem for any Unix/Linux type OS, so the tools available for it are going to be...substandard. You will have much better luck repairing that drive on a system running Windows. There are several ways of solving your current lack of Windows:

  1. The Ultimate Boot CD for Windows: It is a bootable version of Windows plus a bunch of recovery type utilities that you can download and burn to a CD.

  2. Windows 10 Technical Preview is freely a downloadable copy of Windows that you could install onto another partition or drive. This may only work until the release of Windows 10.

  3. Move it. Sometimes the best solution is to just move the drive to another system and fix it there.

    It's kind of like asking how you can change a dead engine on a car without an engine hoist. Answer: Have the car towed to a place that does have an engine hoist.

  • Hmm.. Thanks... I didn't think of those solutions. I'll try them out and report back :)
    – shivams
    Apr 27, 2015 at 5:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .