2

Some function buttons are not being recognized after resuming from sleep. systemctl suspend is used. The buttons work fine after boot and before the sleep but not after. I have tested these with xbindkeys -k in X and showkeys --scancodes on another console and the buttons are being recognized before the machine goes to sleep, not recognized after it wakes. Tried putting it to sleep with another mechanism uswsusp but it did not make any difference.

The buttons not recognized are some (not all) of the function keys located on the top row of the keyboard, such as brightness up/down (fn + f6/f7), mute (fn + Esc), suspend to ram (fn + f4 on my setup). To make it more awkward the volume up/down (fn + 3/4) function buttons work fine all the time.

I have also noticed closing the laptop lid does not always trigger entering the sleep mode, it is very intermittent. This is controlled by systemd. I did not modify the /etc/systemd/logind.conf file at all, it should execute the default action (which is suspend for the lid close) but it not always does. Even if I do modify the file it is still the same, intermittent at best.

It beats me.


Arch Linux, Toshiba portege z830, systemd, very simple setup, dwm display manager, installed very few packages and done very little changes from fresh arch install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.