When I drag a file, it doubles my mouse cursor with icon of the file. Image below shows how it exactly looks like. After dragging completed, the cursor should be normal again but it stays like that. Is there any way I can disable this feature?

http://puu.sh/hacY9/d5cb9a9ece.jpg (taken from this Reddit http://www.reddit.com/r/elementaryos/comments/329fj4/is_freya_buggy_for_anyone_else_could_anyone_offer/)

3 Answers 3


This is a bug that affects the Ubuntu lts-utopic hardware enablement stack (which is what elementary OS Freya uses). You can see the bug report here: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1390625

If you experience the bug, you can reset your cursor by logging out or changing TTYs (Ctrl + Alt + Fn).

  • Does that mean that the same issue should appear on the same machine in Ubuntu 14.04? Or even in Mint 17.1 Rebecca which also uses Ubuntu LTS Utopic? Because, as far as I can tel, it does not appear. I only see this in eOS. I have tried multiple 14.04 ubuntu-based distros on the same laptop, and even now I have one in multiple boot along eOS.)
    – user32012
    Jul 13, 2015 at 18:40

As has been said, this does seem to occur with other Ubuntu versions as well.

Initially I was logging out then used Windows key+L to lock the screen then log back in. This way you can keep your apps open.

Alternatively you could try the following from Moch Sholichudin (ms-patrik99) on the Elementary Os Bug list ref 1430587:

Fixing this problem is rather too easy. Open a terminal (Ctrl+Alt+T) and use the following command:

$ gsettings set org.gnome.settings-daemon.plugins.cursor active false

source: http://itsfoss.com/invisible-mouse-cursor-ubuntu-1310/

Another user Gabriel Couto (gmcouto) said that this didn't work initially but setting it back to 'true' afterwards did.


The simplest workaround I found: use the cycle display shortcut.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .