0

Since the upgrade to Gnome 3.16, my /etc/X11/xorg.conf.d/20-intel.conf file is being ignored.

This file contains the following:

Section "Device"
    Identifier "card0"
    Driver "intel"
    Option "Backlight" "intel_backlight"
    BusID "PCI:0:2:0"
EndSection

It is necessary on my system to control brightness after sleep.

/usr/lib/gnome-settings-daemon/gsd-backlight-helper is ignoring this configuration file. How do I configure gsd-backlight-helper to use the correct backlight device (/sys/class/backlight/intel_backlight) instead of the faulty one (/sys/class/backlight/toshiba)?

  • Thanks for the information. I'll edit my question accordingly. – To Do May 12 '15 at 7:09
  • The '/sys/class/backlight/toshiba' device works only until I suspend my laptop. – To Do May 18 '15 at 6:17
1

This AUR package solves the problem. It patches gnome-settings-daemon to prefer raw type backlight devices to platform ones.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.