1

I was installing AMD gpu driver but the default display driver (Gallium 0.4 llvmpipe) wont get replaced. Btw, My laptop has both Intel and AMD gpu. The system uses Intel gpu by default with the driver Gallium 0.4.

Here's my GPUs:

root@kali:/# lspci -v | grep -i 'VGA\|Display'
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Grap
ichs Controller (rev 09) (prog-if 00 [VGA controller])
03:00.0 Display controller: Advance Mirco Devices [AMD] nee ATI Device 6660

Here's the link I followed to install the driver: Install AMD ATI proprietary fglrx driver in Kali Linux 1.0.6

I was able to install all the prerequisites/dependencies and the driver without any error and I was able to run aticonfig --initial to create an xorg.conf file. I also added the line radeon.modeset=0 to grub.cfg

After the installation, I run fglrxinfo and it returned
display: :0.0 screen: 0
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x209)
OpenGL version string: 1.4 (2.1 Mesa 8.0.5)

I was curious that I'm not running Kali Linux on VM (I installed it on my laptop). I rebooted my laptop, all was working fine until I got stuck on a all black with a non-blinking cursor. I launched a console via ctrl+alt+f1 and purge all fglrx. Deleted the xorg.conf and removed the radeon.modeset=0 to the grub.cfg.

I was wondering where did I go wrong or there's no way to install these drivers on my laptop?

Btw, my AMD GPU is AMD RADEON HD 8670M and my Intel one is Intel HD Graphics 4400. I really need the AMD GPU for pyrit.

  • I had the same problem last week. EXACTLY the same. I solved it by enabling legacy and UEFI in my BIOS boot settings. Good luck! – david May 2 '15 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.