3

Am using an open source .vimrc file from GitHub, but it is screwing up my default mouse right click, copy-paste actions. Whenever I do a right click, it enters into the visual mode and I am having a hard time, doing a copy-paste when I'm inter-working with my Windows machine.

Let me know what .vimrc config lines to delete.

Am running a Red Hat Enterprise Linux Server release 5.4 (Tikanga)

  • In the file you propose, lines 105 -- 108 mention the mouse. Have you tried removing these ? – Vincent Nivoliers Apr 24 '15 at 10:58
3

As @VincentNivoliers said in his comment, your issue comes from the line mouse=a. It enables the mouse in all modes of vim, ie letting you put the cursor where you click.

a means this is active in all modes. If you don't want vim to care about your mouse, just set mouse= (no value). Then, you could use your mouse to copy'n'paste from your clipboard as in a terminal.

From vim documentation:

The mouse can be enabled for different modes:

  n   Normal mode
    v   Visual mode
    i   Insert mode
    c   Command-line mode
    h   all previous modes when editing a help file
    a   all previous modes
    r   for |hit-enter| and |more-prompt| prompt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.