0

umask is creating lots of problem to me . I tried following .

I have commented umask set entry in /etc/profile and /etc/bashrc . There is not even single file in my home direcotry where i set umask . I have changed UMASK in /etc/login.defs to 011 . When i log in and run umask still it shows me 022 . It should show me as 011 right ?

I am using centos 6.6

1

The UMASK parameter of /etc/login.defs is used when you create new users.

For what you're trying to do, editing /etc/profile and /etc/bashrc is a good idea since those files are usually sourced by users.

When umask is not defined, then it has the default 022.

2
  • Ohh.. thanks. I am using clish as my shell for one user. But there is not settings for clish to set umask. Now how to handle umask for clish shell ? – Niraj Apr 23 '15 at 10:34
  • @Niraj Good question... umask is usually a shell builtin. I really don't know how to manage it with clish, sorry :/ (actually, I've never heard about clish before...) – apaul Apr 23 '15 at 11:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.