0

I crated a virtual interface as indicated in this link.

sudo modprobe dummy
sudo ip link set name eth10 dev dummy0
sudo ifconfig eth10 up
sudo ifconfig eth10 192.168.1.150

now if I want to make a ping to a host in my network (ping 192.168.1.133), then the ping will not work.

I tried to add

sysctl -w net.ipv4.conf.eth10.forwarding=1

But the ping does not work neither.

What should I have to add to make the ping works?

closed as unclear what you're asking by Jeff Schaller, Rui F Ribeiro, msp9011, countermode, icarus Sep 1 '18 at 2:38

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • You say ping doesn't work. What specifically happens when you run ping? What error messages do you get? – Kenster Apr 23 '15 at 13:43
1

Dummy interfaces won't do anything until you make them part of a bridge.

As this is an old question and the asker is not explaining what he actually wants to achieve, and it's impossible to guess this, the question is difficult to answer.

The most straightforward way is to create a bridge on an ethernet interface etc., but then you could have just added the address to the ethernet interface in the first place.

-1

Is it correct, you want to use your eth10 interface as source interface to make ping 192.168.1.133? If yes, you should use ping command with -I option and specify source IP address, or source interface name. Here is an example:

ping -I 192.168.1.150 192.168.1.133

or

ping -I eth10 192.168.1.133

Not the answer you're looking for? Browse other questions tagged or ask your own question.