1

I'll make this fast. OpenSUSE is throwing up a whole bunch of errors when I try to install it. I am 90% sure that the partitions I set up are correct, but the installer doesn't seem impressed by my efforts. The error messages I got can be found here:

The Before and After labels indicate the partition setup that I ATTEMPTED to create: Before After failure setting disk label failure setting disk label failure mounting sdb3 failure mounting sdb1 failure mounting sdb2 failure formatting sdb3 failure formatting sdb2 failure formatting sdb1 failure creating volume sdb3 failure creating volume sdb2 error occurred during initrd creation

The phrase "unrecognised disk label" keeps coming up. Did I skip a step? I thought that labels were optional?

Oddly, Gparted does not seem to agree with SUSE on the disk's contents. This concerns me.

gparted sdb gparted sda partition list

Additional info:

user@debian~$ sudo parted /dev/sdb unit s print 
Error: /dev/sdb: unrecognised disk label
Model: ATA KINGSTON SV300S3 (scsi)
Disk /dev/sdb: 234441648s
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
13
  • so you have to disks sda and sdb but sdb is the one with troubles?... Did you check if the drive is ok... ¿badblocks?
    – maniat1k
    Apr 23, 2015 at 1:15
  • Yes, sda is a 2TB HDD and sdb is a 120GB SDD. Both drives worked just fine last week. The SSD is less than a year old, so I can't imagine it going bad already.
    – flazzo
    Apr 23, 2015 at 2:11
  • They both seem to be acting oddly though. sda seems to sprout a set of Linux partitions while sdb is left with nothing. Could the installer be trying to write the OS onto sda even though the partitions were set up on sdb?
    – flazzo
    Apr 23, 2015 at 2:12
  • No. That's not it. Removing the HDD didn't change the result at all. So now I have an SSD that refuses to be formatted.
    – flazzo
    Apr 23, 2015 at 3:28
  • Tried the same thing with Debian. Got similar results. "The ext4 file system partition creation in partition #2 of SCSI1 (0, 1, 0) (sda) failed"
    – flazzo
    Apr 23, 2015 at 5:02

1 Answer 1

0

Is the partition unallocated? Because from the picture in the beginning, where it says "Setting disk label of /dev/sdb to GPT" I think it's trying to give the hard disk an partition-table "GPT".

I'll suggest that try allocating the partition.

You could try the solution found from this link: OpenSuse Support

  1. Boot and run opensuse live.
  2. Open up the Terminal.
  3. Gain ROOT privileges.
  4. List the disks with the "fdisk -l" command.
  5. Then use cfdisk(8) and delete the space you want use for installation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .