I used to connect my Ubuntu 14.04 laptop on office network via eth0 and the route table gets updated with the office network gateway IP in auto mode.

Now, I changed my /etc/network/interfaces configuration to add a bridge interface, br0, and made eth0 as a dumb port inside br0. My /etc/network/interfaces has:

iface br0 inet static
   address X.X.X.X
   bridge_ports eth0
   bridge_stp on
   bridge_fd 0
   gateway X.X.X.X

My route table is no longer getting updated. Every time I plug in my ethernet cable, I need to do:

route add default gw X.X.X.X br0

How to configure the default gateway for a bridge?

  • I have the same problem on a machine with Ubuntu 16.04. In fact, the default gateway is created, but it uses the eth0 device underlying the bridge and this interface is marked as down. Manually setting the default gateway as mentioned in the question works.
    – ph0t0nix
    Commented Jan 10, 2017 at 8:33

1 Answer 1


The default gateway normally gets updated by dhcp.

However, in your /etc/network/interfaces, you state that, for br0 the inet is static. You specify explicitly the IP address, netmask and gateway. So, no dhcp request is done for this interface.

If you want the default gateway updated, specify as:

auto br0
    iface br0 inet dhcp
    bridge_ports eth0

You must log in to answer this question.