0

Unable to perform write & execute actions on ntfs partition. ls -l shows that user have only the read permission. Group any others have non. i tried to copy some text from home to windows partition with root privileged. then an error is shown

[root@dazz dazz]# cp test.txt /run/media/dazz/943C95C53C95A332/        
cp: cannot create regular file ‘/run/media/dazz/943C95C53C95A332/test.txt’: Read-only file system

I tried the same with elementary os. no issues. i can read write and execute normally.

2

As the error message states, your filesystem is mounted read-only. If you are using kernel NTFS driver, it does not mount filesystem read/write, as that is considered unsafe. Your best bet is to use ntfs-3g, which IIRC, does read/write mount by default and is considered safe for writing.

0

As I can see the ntfs partition in mounted in /run/media/dazz/943C95C53C95A332/ so it can be automounted. In the case some distribution on default mount ntfs partitions with read-only flag and most with no-exec option.
You are able to remount partition manually with -o rw,exec or refer to your distro manual to set automount options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.