1

I am able to detect my wireless connection, just unable to connect. I have used NetworkManager and WICD and they both keep asking for the password when I know I have entered it correctly.

My router is dual band and I am using WPA security.

The USB adapter is a Netgear WNDA3100 v2 which I installed using ndiswrapper.

Here is what mintwifi outputs:

-------------------------
* I. scanning WIFI PCI devices...
-------------------------
* II. querying ndiswrapper...
bcmn43xx64 : driver installed
        device (0846:9011) present
-------------------------
* III. querying iwconfig...
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11g  ESSID:off/any  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated  
          Bit Rate:300 Mb/s   Tx-Power:32 dBm  
          RTS thr:2347 B   Fragment thr:2346 B  
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

-------------------------
* IV. querying ifconfig...
eth0      Link encap:Ethernet  HWaddr 54:04:a6:0b:c8:51  
          inet addr:192.168.137.123  Bcast:192.168.137.255  Mask:255.255.255.0
          inet6 addr: fe80::5604:a6ff:fe0b:c851/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:661379 errors:0 dropped:0 overruns:0 frame:0
          TX packets:384399 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:937091138 (937.0 MB)  TX bytes:34762843 (34.7 MB)
          Interrupt:46 Memory:fe400000-fe420000

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:4776 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4776 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:464604 (464.6 KB)  TX bytes:464604 (464.6 KB)

wlan0     Link encap:Ethernet  HWaddr c4:04:15:6d:5b:de  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

-------------------------
* V. querying DHCP...
RTNETLINK answers: File exists
-------------------------
* VI. querying nslookup google.com...
Server:         192.168.137.1
Address:        192.168.137.1#53

Non-authoritative answer:
Name:   google.com
Address: 216.58.209.238

Edit

I am able to connect to my router with the same version of Linux Mint with a laptop although that is using a built-in adapter which didn't require ndiswrapper to get working.

I am currently connected to said laptop through an Ethernet connection which is sharing the wireless connection to the router.

Also my PC is able to connect to the router when using windows 7.

  • try service network-manager restart, connect again and enter password to see if it works. always the first thing I try.. – cremefraiche Apr 17 '15 at 21:37
  • @cremefraiche I just tried this and still it asks me for the password – Emobe Apr 18 '15 at 0:59
  • How close are you to the router? – cremefraiche Apr 18 '15 at 1:24
  • @cremefraiche see edit in question – Emobe Apr 18 '15 at 1:32
  • 1
    Yup, sorry I couldn't help further. For what it's worth, the TP-Link TL-WN722N is an inexpensive 4dbi adapter capable of monitor/master modes and is plug&play with most distros. It operates on the ath9k chipset if you want to check compatibility. – cremefraiche Apr 18 '15 at 2:06
0

Came to the conclusion that my USB adaptor wasn't compatible and bought a TP-Link TL-WN881ND internal WiFi card and that worked perfect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.