1

I purchased a multidomain certificate, and I was trying to install it on my server.

I put the following information inside the virtual host for one of my sites:

<VirtualHost *:443>
...
SSLEngine on
SSLCertificateFile /etc/apache2/ssl/16478325.crt
SSLCertificateKeyFile /etc/apache2/ssl/private.key
SSLCertificateChainFile /etc/apache2/ssl/16478325.ca-bundle
...

I then tried to restart apache, and got a failure, and I was told to check my apache logs.

The error message received was this:

Init: Multiple RSA server certificates not allowed

I assumed that that meant I had to install an SSL certificate for the entire site, not on one domain.

But that also did not work.

I got the error:

Illegal attempt to re-initialise SSL for server (SSLEngine On should go in the VirtualHost, not in global scope.)

Why isn't this working? How do I configure my domains to each have SSL?

5

(summary of comments)

You have a conflicting SSL virtual host from the Ubuntu/Debian default-ssl virtual host. a2dissite default-ssl will fix the immediate problem.

The Apache HTTP Server Wiki has a guide to configuring name-based SSL virtual hosts which you should review. The guide shows them all in one file, but you can split the different VirtualHost sections to different files (in sites-available/)—they're all included in the main config anyway. You can put stuff like the NameVirtualHost line in ports.conf or in conf-available/. /usr/share/doc/apache2/README.Debian.gz contains some documentation on the Debian/Ubuntu apache config handling.

0

You need to make sure you comment out the boiler plate SSL lines above in the config file.

    #SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
    #SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
    #SSLCertificateChainFile /etc/apache2/ssl.crt/server-ca.crt

I ran into this same problem a moment ago and found your question before I realized it was pilot error on my part.

Otherwise, everything works with multiple certs on the same host (meaning two VirtualHost configurations for port 443 on the same host.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.