6

In the top bar, clicking the network icon shows a list of networks. My school's network, which on Windows I would connect to, and then visit a login page in Chrome in order for it to work, shows on the list.

When I click to connect it shows it connecting, and then says that I am not connected to the Internet.

I am using elementary OS 0.3 Freya.

Running iwconfig shows

eth0      no wireless extensions.

wlan0     unassociated  Nickname:"rtl_wifi"
          Mode:Managed  Access Point: Not-Associated   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.
  • Have you tried loading up any page in your browser after connecting? Would have thought this would automatically redirect you to a login page. wlan0 will be your wifi adaptor/card, so you're associated with the network just not authenticated via whatever web app system they use. You need to force the network to redirect you to that page. What browser are you using? Firefox? – py4on Apr 17 '15 at 17:04
0

Many school/college network auth systems don't play well with certain browsers. I know Midori is the default on Elementary OS so download Firefox and try loading up a page in this after connecting.

EDIT: Ok, just to cover the obvious, if you're switching OS's a lot this might be down to something as silly as misconfigured keyboard.. Try typing the network password into a plaintext doc and make sure characters like @ or ~ are mapped correctly.

EDIT 2: Just realised that your combination of command line and gui network connection tools may be problematic. Try disabling network-manager with sudo service network-manager stop then connect with sudo iwconfig wlan0 essid NAME_OF_NETWORK then dhcp with sudo dhclient -v wlan0. Then (pending a successful connect) fire up a browser.

  • The problem is, it won't connect in the first place. After the "connecting" process, where the spinning loading symbol replaces the network symbol, it simply stops spinning and shows me a pop-up notification saying the standard "you are are now offline/disconnected" message. I updated Elementary using ethernet and this problem persisted. I also installed the lastest Ubuntu and this problem persisted in the exact same fashion. I also reset the network manager, and the network menu stopped showing wifi networks. Unplugging and plugging back in my adapter showed the networks again. – Connor Elsea Apr 17 '15 at 17:30
  • See edit above. Also I'm presuming you've managed to successfully connect to other networks with this same adaptor? – py4on Apr 17 '15 at 18:05
  • While you try the above, also run sudo tail -f /var/log/syslog immediately after trying to connect again and paste everything referring to wlan0 and the failed attempt. – py4on Apr 17 '15 at 18:10
  • I will do this command and get back to you. But please understand that the network has no initial password to "type in". It appears as a free and open wifi network. Also there are no other wifi networks so I haven't tried to connect to them. I will run that command. – Connor Elsea Apr 17 '15 at 18:14
0

Schools and enterprise organizations usually use WPA2 Enterprise and PEAP combination as the security protocol and authentication method respectively. You will have to configure this. Assume Elementary OS uses Network Manager to manage network connections, click the network icon. Next Click "Edit Connections..." from the drop-down menu. You should see a dialog with "Network Connections" as the title which shows a list of networks you have connected to or attempted to connect to. Choose your school wifi and click Edit. This image shows how to configure the network. When you are finished click Save... and try reconnecting to your schools wifi.

0

I've had trouble logging in to school and other public wifi networks which require agreeing to terms of service.

The trick was to connect to the wifi network, but then not go to a site with "https://.com". Instead, attempt to log into a site with http (not https), so "http://cnn.com".

This brought up the "agree to terms" page and allowed me to connect.

0

I have the same problem with my university they are using mikrotik routers some times I need to disconnect the WIFI and connect to another one and it works,I use Firefox on xubuntu 14.04 Just enter a google home page and type the username then use it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.