5

I am running Kali Linux in a virtual box (VMWare Player), and although the resolution fits my screen properly, the icons, windows, text is so small. In example, when I use the terminal or browse using Iceweasel, the windows they appear in show small text, and everything is not proportioned properly to size.

It seems that everything has shrunk in size; even the dropdown menus on the desktop, and windows that open are not properly displayed regarding size.

How can I increase the size so that windows, text, desktop icons and desktop menus display properly (standard size)?

  • Have you installed vmware tools? – zer0rest Apr 16 '15 at 11:27
  • No. If I do, what solution can they provide? What can I do with them? – naltun Apr 16 '15 at 11:36
  • Automatic resizing, integration with shared folders between host and guest, seamless mode(show windows in host OS). See docs.kali.org/general-use/install-vmware-tools-kali-guest – zer0rest Apr 16 '15 at 11:43
  • @zer0rest , nested hypervisor is illegal. You can't install nested. – PersianGulf Apr 16 '15 at 14:01
  • @MohsenPahlevanzadeh, do you know how to rescale my virtual machine's instance? – naltun Apr 18 '15 at 9:43
3

When you installed Guest Additions to your VBox Kali, there should be a bar at the bottom of your screen that shows up every time your cursor is there at the bottom (with options: File, Machine, View, Input, Devices, Help, Kali). I cannot take a screenshot of the bar but you should be able to find it.

Click on the View option, and you can choose full screen or seamless or whichever you like. But with high solution the icons will be small as you mentioned. It's okay because you can see at the bottom of the View list you have "Scale Factor", move your cursor on it and it will show different scaling such as 125% or 150%. I find 125% and 150% suit my screen the best.

1

Just search for "tweaks" which is already on Kali. Go to fonts->interface. Change to whatever font you want

You can also right click on the dock to open "dash to dock" which lets you change fontsize

0

You can go to about:config-> select and agree the warning and search for layout.css.devPixelsPerPx select it by doubleclick and set value to 2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.