6

KWallet requests a password on startup. I want to get rid of this but I have found no way to disable it and also cannot remove KWallet itself:

# sudo pacman -R kwallet
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: kio: requires kwallet

How can I stop this password prompt from appearing each time I log in? I am using Arch Linux and Plasma 5.

8

You can

  • remove the password from the wallet. Start the kwalletmanager and then click on »change password«.
  • disable the wallet. Start the kwalletmanager and go to settings / configure wallet. Uncheck the box »Enable the KDE wallet subsystem«.
  • Remove the password worked for me in plasma 5 ( disable wallet not ) – Francesco Nov 17 '16 at 11:19
  • When I run kwalletmanager5 on kubuntu 16.04, it just exits 0 without doing anything. – dannyman Jul 19 '17 at 3:11
1
sudo pacman -Rdd kwallet

Worked for me

  • 1
    Why do you think that worked? (A little explanation in answers is always nice) – Jeff Schaller Jan 28 '17 at 12:13
  • This is not a good idea, since you are actually telling pacman to not take dependencies into account. This might lead to crashes (some binaries depend on libs provided by this package), and also means the package will be re-installed anyway on any further depending program install or update. – Archange Jul 3 '18 at 17:27
1

You can create or edit ~/.config/kwalletrc with the following content:

[Wallet]
Enabled=false

This has the advantage of not requiring to install kwalletmanager just to disable it.

  • You may also need to add Prompt on Open=false to the same section of this file. It will disable kwallet pop-up window every time a KDE application wants to deal with passwords. – scrutari Jul 2 '18 at 10:57
  • In my experience Enabled=false was enough for that too, but of course it does not cost much to also add your line. – Archange Jul 3 '18 at 17:28
  • The problem with this is you dont get your password stored. So its equally anoying. you dont type the kwallet password pbut you get to type other passwords over and over again. – jstuartmilne Mar 29 at 11:40
  • @jstuartmilne Well the question was about disabling kwallet, not using it without password. – Archange Mar 30 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.