2

I'm using Arch Linux and currently installed Xfce4, which after I log in (using LigthDM) opens an instance of the Nemo file browser. This happens regardless what I set as the default file browser (I also tried Nautilus and Thunar). This happens only with Xfce4, using Cinnamon or Gnome doesn't reproduce this behaviour.

I checked the Application Autostart settings from the Session and Startup menu, but there is no entry for Nemo or any other file browser. I also checked the contents of /etc/xdg/autostart/ and ~/.config/autostart/, but there aren't any file browser related entries.

Any idea where this behaviour could be originated, or any suggestions what I could try next?

  • Did you grep or ls the contents of autostart? – Fabby Apr 14 '15 at 11:45
3

You may have something recorded in your session. Logout from XFCE (ie: logon with another WM or from console), then remove files named xfce4-session* and xfwm4* from ~/.cache/sessions/. Then try to logon with XFCE again.

  • that seems to have solved it :) there was one xfce4-session... file which somehow contained the line Legacy0_Command=nemo. The newly generated file doesn't contain any Legacy... entries – tschale Apr 14 '15 at 12:30
  • and it is back... for some reason nemo gets an Legacy entry in the session-file, although session-saving is disabled... – tschale Apr 14 '15 at 12:40
  • 1
    @tschale I've never used nemo, but after some research, it seems nemo doesn't really exit when one use it out of cinnamon. Try to launch it with nemo --no-desktop or quit it with nemo -q. See here for instance. – apaul Apr 14 '15 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.