So, there are thousands of questions related to this all over the internet, but, after days of searching, I still can't find a solution!

I have a Turnkey server that was pre-configured with MineOS, it's been running fine, 24/7, for the last month or so, but then the server stopped working and I couldn't interact with the web server or anything, so I physically turned it off, and when I turned it on again, it showed me this screen;

GRUB loading.
Welcome to GRUB!

error: unknown filesystem.
Entering rescue mode...
grub rescue>

From here, just about all of the tutorials say that you should use ls to find your drive and boot, the only problem with that is that there are 2 hard drives; one 50GB ext4 Turnkey OS disk, and a 250GB NTFS Storage disk. The 250GB NTFS HDD doesn't appear, and using ls on (hd0), (hd0,msdos5), (hd0,msdos1) all return;

grub rescue> ls *
error: unknown filesystem.

It's also the same issue when I try;

ls (hd0,msdos#)/
error: unknown filesystem.

I'm completely stuck, there appears to be no way to boot into MineOS, if I get my Ubuntu disk, I'm able to access all the hard drives and the data inside them, with the exemption of the fact that I only have read access to the files, as I aren't the owner.

UPDATE 1

I've found out some more information about the partitions in this computer, the first hdd is /dev/sda this is the 250GB ntfs hard drive, this wasn't originally sda, it used to not be mounted whatsoever, so I suspect this may be the problem, but unplugging doesn't make any difference as far a grub is concerned. The second hdd is /dev/sdb. This includes a 250MB ntfs boot partition; /dev/sdb1. And Turnkey, the rest of the linux filesystem (/dev/sdb5), within an extended partition; /dev/sdb2. Plus, the sdb hdd is managed in lvm, these are all the default setting provided with Turnkey + MineOS.

UPDATE 2

As per dr01's suggestion, I've tried the boot-repair-disk, seemingly, it worked, it threw a few errors, of which have been reported, here's the pastebin of the log of boot-repair-disk; http://paste.ubuntu.com/10824961/ . But the reason as to why I haven't posted this in the answer section is because, technically, the problem has been solved, but it only half fixed it. Now, instead of getting stuck in grub rescue, grub starts as normal, then shows the below text;

GRUB loading
Welcome to GRUB!

error: no device connected.
error: no device connected.

It then waits 10 seconds, and switches to the GNU GRUB (version 1.99-27+deb7u2). From a very helpful tutorial I found here, ls now returns:

(turnkey-swap_1) (turnkey-root) (ata0) (ata0,msdos5) (ata0,msdos1)

I'm struggling to understand why I now have an ata device, but at least grub can access the filesystem to the extent of getting here, but I can't find any guides as to how to boot up Turnkey via grub, as the tutorial above and plenty of others I found didn't work.

For anyone unfamiliar with turnkey, the root filesystem is (turnkey-root), but from there, I've been pretty confused, for a start:

 grub> cat (hd0,1)/etc/issue

doesn't work. And I can't find vmlinuz anywhere, there is what I presume to be a link in the root called "vmlinuz", but if I

grub> linux /vmlinuz
error: file not found.

And it's the same with the mentioned tutorial, it recommends typing 'grub> linux /boot/vmlinuz' and then hitting tab, this returns nothing. Perhaps this was the boot-repair-disk re-installing grub and deleting the contents of /boot, at the same time then failing to recreate the vmlinuz image, but whatever it is, I'm stuck again and I have no idea what to do.

up vote 2 down vote accepted

You could give a try to boot-repair-disk to have it repair your GRUB. It has worked very well for me in the past.

  • I've done that, but now there's more problems. I've added tonnes of information above. – Asriel Repp Apr 15 '15 at 6:03
  • I have absolutely no idea how this worked but it did, thank you. – adrianmann Oct 4 '15 at 12:10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.