3

Trying to understand the whole journalling setup and from what I've read and tried, it's eluding me somehow.

The root filesystem is ext3. Examining it via tune2fs -l /dev/root shows that 'has_journal' is present. "Good", methinks, "this should be easy!".

Not so fast there, hotshot. I added 'data=journal' to the line in fstab (originally, I had 'defaults,data=journal' but later dropped the 'defaults' entry).

Also added 'rootflags=data=journal' to my 'kernel xxx' line in grub.conf.

Rebooted, filesystem is mounted read-only and I need to horse around with it to get it writable. The 'mount' command did nothing so I had to examine /proc/mounts for any info.

I had also tried adding 'data=journal' to all of my ext3 filesystems, and some appeared, via /proc/mounts, to be mounted with data=ordered and others with data=journal... why the difference there?

How do I get the root filesystem mounted rw with journalling? OS is CentOS 5.4.

0

If the file system is mounted as type ext3, file system journaling is turned on by default, no need to specify it explicitly.

The ext3 file system type can be specified explicitly with the '-t ext3' option to the mount command or in the type column in /etc/fstab. Normally, you should not removed the 'defaults' option for the the root file system in /etc/fstab.

0

I found this page, which directed me to hack up my initrd. Once I did that, things began to work. Not sure I understand exactly why I needed to do that, but it's working now.

Question... what filesystem(s) should not be mounted with journalling enabled? tmp? swap? others?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.