1

I recently installed Debian Wheezy and sound doesn't work (glitches/distortions).

Output of lspci -v | grep -A 6 Audio:

00:1b.0 Audio device: Intel Corporation Wellsburg HD Audio Controller (rev 05)
    Subsystem: Dell Device 0617
    Flags: bus master, fast devsel, latency 0, IRQ 69
    Memory at fb130000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel

02:00.1 Audio device: NVIDIA Corporation GF119 HDMI Audio Controller (rev a1)
    Subsystem: NVIDIA Corporation Device 094e
    Flags: bus master, fast devsel, latency 0, IRQ 36
    Memory at fb080000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel

It seems Intel Corporation Wellsburg HD Audio Controller uses chipset ALC280 and I suppose it is not supported?

I really could not find a working solution for this problem.

Output of uname -r:

3.2.0-4-amd64

How should I proceed?

  • use lspci -v | grep -A 6 Audio it should say "Kernel driver in use" and that will show if there is a driver in use for the card or not. – mchid Apr 13 '15 at 21:23
  • Thanks for the prompt reply. I just updated the question. – sigma Apr 14 '15 at 8:50
  • Do you have the alsa-utils installed? if so, you need to run alsamixer in an open terminal and turn automute off as it is on by default. Also, sometimes it helps to also press F6 and then select your card from the list (also using alsamixer). – mchid Apr 14 '15 at 9:07
  • The card is not on mute, I have checked that. The problem is crackling/distorted sound. – sigma Apr 14 '15 at 10:09
1

So, apparently there is an incompatibility issue with ALC280 chipset and kernel 3.2.0-4-amd64.

My solution involved downloading the Realtek Linux driver (3.0) from here, unpacking it, and configuring it for Intel sound cards, using:

./configure --with-cards=hda-intel

then running

make
make install

Since I am using ALSA and PulseAudio, I ran

sudo purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio 
sudo alsa force-reload

to reset some settings, then I checked whether there is an option line for snd-hda-intel in the alsa config file by running

cat /etc/modprobe.d/alsa-base.conf 

and commented out (or removed) the line

options snd-hda-intel position_fix=1 model=medion

then rebooted.

I also made sure to unmute ALSA, by running alsamixer and using "m" to unmute all channels.

And everything worked.

I would like to thank this tutorial for providing some useful information as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.