I'd previously used aufs2 in aufs-tools with some luck, but apparently this package has been "superseded" (this is strange term to use for a package which seems to have been removed only because it no longer compiles, but never mind).

Okay, so I thought I would try to use unionfs-fuse. I can't for the life of me figure out how to make it work for users though.

I'm using this command to make my unified mount:

unionfs-fuse /mnt/disk1-pool=RW:/mnt/disk3-pool=RW /mnt/union-pool

When I run this as root, I cannot access this share as joe user:

$ ls -al /mnt

ls: cannot access /mnt/union-pool: Permission denied
d??????????  ? ?    ?       ?                ? union-pool

When I run it as joe user, I cannot access this share as root. I basically get the exact same output as above. This is a little weird to me, root being root.

Both root (obviously) and joe user can access the /mnt/disk1-pool and /mnt/disk3-pool mounts.

If anybody has any info about aufs-tools for natty I'd also be interested. I am quite fond of this package because it worked.

2 Answers 2


I suppose (but not tried) that the fuse option -o allow_other, also shown in the example in the unionfs-fuse's man page, could be of help.


Try this

sudo mount -t aufs -o br:/mnt/disk1-pool=RW:/mnt/disk3-pool=RW \
    none /mnt/union-pool

that seems to work also without aufs-tools package.

  • Bravo! Just out of curiousity how did you know that aufs is still available in Ubuntu 11.04? I was wondering how to get a list of supported filesystem types but could not figure out how to. Also Is there a man page on aufs I can bring up?
    – fostandy
    Aug 30, 2011 at 1:14
  • To answer the first qn: cat /proc/filesystems
    – fostandy
    Aug 30, 2011 at 4:02
  • 1
    I see the output of grep -i aufs /boot/config*, and remember livecd uses aufs, so did a little search and find a script here help.ubuntu.com/community/LiveCDCustomization (search for aufs).
    – enzotib
    Aug 30, 2011 at 6:21

Making a note so that this entry becomes self sufficient. This is a common issue with FUSE based filesystem. The userspace FUSE background process runs with the privileges of the user executing it. The thought process is that by default, anyone other than the owner of the process should not be allowed to access the files under the FUSE mount point. In order to allow others, certain configuration parameters and mount options need to be specified. In /etc/fuse.conf, uncomment user_allow_other. And while mounting, depending on the requirement, add the options allow_root or allow_other

Caution: note that running the FUSE process as root and passing allow_other during mount is a prescription for sleepless nights since any user can gain root access to any of the underlying file systems.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .