2

First question I've asked here so please forgive me if I accidentally break a rule.

I recently set up an ssh server on my home machine, and am using ddclient to keep the dynamic DNS service at home_hostname.my_domain.me updated with the home machine's address. The domain and the dynamic DNS service are provided by Google Domains.

When I try to ssh or remote desktop (using VNC) into my home machine from work via ssh home_hostname.my_domain.me or the Remmina VNC client, I somehow end up connecting back to my own work machine. I tried this from several different computers, all with the same result: the DNS server directs them back to themselves.

Can anyone explain what I did wrong to cause this, and how to fix it? If my ddclient conf files are needed to diagnose the problem I can provide them in a few hours when I get home from work.

  • What do you get when you nslookup home_hostname.my_domain.me ? – John Apr 10 '15 at 17:46
  • @John: Server: 127.0.1.1 Address: 127.0.1.1#53 Non-authoritative answer: Name: [home_hostname.my_domain.me] Address: 0.0.0.0. That would explain it... although I still don't know why it's happening. Thanks for letting me know about nslookup. – jzimbel Apr 10 '15 at 17:48
1

Your ddclient is getting an invalid address for your home machine(s).

You have to configure your ddclient to get your external home address, and you will very likely have to configure port forwarding on your cable modem or other external-facing device to get this to work.

0

Adding to John's answer, the problem ended up being that I had configured my ddclient incorrectly. Changing use=if, if=eth0 to use=web in ddclient.conf fixed the problem for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.