2

Scenario

  • allready running Apache Webserver 2.4.2 on Solaris 5.10
  • newly added nfs mount as target for copying files via php
  • executing cp via shell with the same user as the webserver works
  • copying via Webserver/php doesn't work, it gives permission denied in the apache error log (no matter if using phps copy, exec or shell_exec)

Solution

After restarting the apache webserver everything works fine.

Question

Why is that? As far as I know file- and directory-permissions are (have to be!) checked per/on execution, or not? Plus if not calling something that uses the new mountpoint, the apache doesn't even know of it.

2
  • do you have caching enabled? usually mod_cache or similar Apr 15, 2015 at 2:51
  • No, it isn't enabled: All modules containing cache in its name aren't loaded.
    – evilive
    Apr 15, 2015 at 5:36

1 Answer 1

0

My guess would be (although I've never done this before, I've always had the nfs mount up first) is that the running user didn't have access until it was reloaded - either it didn't know about it or something along those lines. Never tried this before though so I'm not really sure

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .