0

I'm triying to install VNC Server in a Red Hat Enterprise Linux Server release 6.5. I have the .rpm of VNC Server, but it has a depedency with xterm, which I have the .rpm too. Trying to install xterm it shows an error of dependencies too, this is the message:

error: Failed dependencies:
    libXaw.so.7()(64bit) is needed by xterm-293-25.1.x86_64
    libXmu.so.6()(64bit) is needed by xterm-293-25.1.x86_64
    libXpm.so.4()(64bit) is needed by xterm-293-25.1.x86_64

These dependencies I'm not able to find them and I cannot use yum command.

Anyone can help me to find out where I can download the suitable version for my system and tell me how to install them?

0

Library "libXaw.so.7" is provided by package with name "libXaw-1.0.11-2.el6.i686". Download and install this package and then try to install vnc package/rpm

0

Is there a reason you can't use the yum command? Also, are you trying to install tigervnc-server? Either way, you can approach this by using either:

rpm -q --whatprovides libXaw.so.7 or yum provides libXaw.so.7 to find out what packages provide this shared object.

You should look into creating a repository from the RHEL 6.5 server install disc Create RHEL Repo. This way, resolving dependencies will become much easier, especially when they are apart of the main distro. Once you have a repository, simply run yum install tigervnc-server

  • I cannot use yum command because of security. The machine where I'm currently working has not access to internet. rpm -q --whatprovides libXaw.so.7 shows this: no package provides libXaw.so.7 – Alavaros Apr 13 '15 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.