4

I have 4 servers on the VirtualBox. Two of the servers are a CentOS 7 cluster with Pacemaker(corosync), and they have an NFSv4 server in Active/Passive mode. There are also 2 clients with CentOS 6, also using this NFS server.

The problem does not always occur, but sometimes when I manually or automatically failover from the active NFS server cluster, both clients give the error: Permission denied. The tcpdump from the clients shows:

[17:24:29.271467] IP client.example.net.34236755563 > server.example.net.nfs 112 getattr [|nfs]
[17:24:29.271619] IP server.example.net.nfs > client.example.net.3423675563: reply ERR 24: Auth Bogus Credentials (seal broken)

Until this problem is solved nothing is working: I have tried to transfer to NFSv3, tried different cluster configurations, tried a grace period for NFSv4 from 10 to 90 seconds, with no luck.

Cluster configuration:

node 1: storage1
node 2: storage2
primitive p_drbd_nfs ocf:linbit:drbd \
    params drbd_resource=cgp \
    op monitor interval=31s role=Master \
    op monitor interval=29s role=Slave \
    op start interval=0 timeout=240s \
    op stop interval=0 timeout=120s
primitive p_fs_home Filesystem \
    params device="/dev/drbd0" directory="/mnt" fstype=xfs options="noatime,nobarrier" \
    op monitor interval=10s \
    meta is-managed=true
primitive p_ip_nfs IPaddr2 \
    params ip=192.168.56.100 cidr_netmask=24 \
    op monitor interval=30s \
    meta is-managed=true
primitive p_nfs_exports exportfs \
    params fsid=0 directory="/mnt" options="rw,async,no_wdelay,mountpoint,insecure,no_subtree_check,no_root_squash" clientspec="192.168.56.0/255.255.255.0" wait_for_leasetime_on_stop=true rmtab_backup=none \
    op monitor interval=10s \
    op stop interval=0 timeout=120s \
    meta is-managed=true
primitive p_nfsserver nfsserver \
    params grace_time=90 proc_num=16 \
    op monitor interval=30s \
    meta is-managed=true
primitive p_ping ocf:pacemaker:ping \
    params host_list=192.168.56.1 multiplier=1000 attempts=1 timeout=3 name=p_ping \
    op monitor interval=5 timeout=60
ms ms_drbd_nfs p_drbd_nfs \
    meta master-max=1 master-node-max=1 clone-max=2 clone-node-max=1 notify=true is-managed=true
clone cl_p_ping p_ping \
    meta is-managed=true target-role=Started
location l_0 ms_drbd_nfs \
    rule $role=Master -inf: not_defined p_ping or p_ping lte 0
colocation c_1 inf: p_fs_home ms_drbd_nfs:Master
colocation c_2 inf: p_nfsserver p_fs_home
colocation c_3 inf: p_nfs_exports p_nfsserver
colocation c_4 inf: p_ip_nfs p_nfs_exports
order o_1 inf: ms_drbd_nfs:promote p_fs_home:start
order o_2 inf: p_fs_home p_nfsserver
order o_3 inf: p_nfsserver p_nfs_exports
order o_4 inf: p_nfs_exports p_ip_nfs
property cib-bootstrap-options: \
    dc-version=1.1.10-32.el7_0.1-368c726 \
    cluster-infrastructure=corosync \
    stonith-enabled=false \
    no-quorum-policy=ignore \
    last-lrm-refresh=1428329105
rsc_defaults rsc-options: \
    resource-stickiness=200

Here is a string from the client fstab file:

192.168.56.100:/        /mnt                    nfs     nfsvers=4,proto=tcp,rsize=32768,wsize=32768,hard,timeo=300,retrans=2,bg,actimeo=3,noatime,nodiratime        0 0

1 Answer 1

0

I've solved this problem after two weeks of unlucky attempts, i found that there is bug in rpc.mountd, and just tried to install a recent version of nfs-utils:

yum update nfs-utils
1
  • Do you have a reference for that bug?
    – Flup
    Commented Jan 18, 2016 at 10:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .