1

I'm trying to get it so i can click on complex mailto links (that have params for subject etc) in a page in Chrome, and that opens the mail in gmail, in Chrome.

I've installed gnome-gmail. Chrome is set as my default browser, in System/Preferences/Preferred Applications. my x-www-browser and gnome-www-browser config are both set to /usr/bin/google-chrome-stable 200 auto mode:

$ sudo update-alternatives --config x-www-browser 
There are 3 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).

  Selection    Path                           Priority   Status
------------------------------------------------------------
* 0            /usr/bin/google-chrome-stable   200       auto mode
  1            /usr/bin/firefox                40        manual mode
  2            /usr/bin/google-chrome-stable   200       manual mode
  3            /usr/bin/opera                  200       manual mode

$ sudo update-alternatives --config gnome-www-browser 
There are 3 choices for the alternative gnome-www-browser (providing /usr/bin/gnome-www-browser).

  Selection    Path                           Priority   Status
------------------------------------------------------------
* 0            /usr/bin/google-chrome-stable   200       auto mode
  1            /usr/bin/firefox                40        manual mode
  2            /usr/bin/google-chrome-stable   200       manual mode
  3            /usr/bin/opera                  200       manual mode

When i open gnome-gmail, it opens in Firefox, not chrome. Various other apps seem to prefer to open firefox rather than chrome.

When i click on a mailto, it opens an empty window in chrome.

I'm confused. Am i missing some config here?

Any help much appreciated! Max

EDIT: i've now made it so that all the apps which used to open firefox (including gnome-gmail) now open chrome instead, by editing ~/.local/share/applications/mimeapps.list and changing all instances of =firefox.desktop to =google-chrome.desktop. So, gnome-gmail now opens chrome. But, when i click on a mailto it still just opens a new empty chrome window.

2

Ok, so maybe this was a bit of a waste of time since the solution has nothing to do with gnome-gmail or the default browser, but i found the answer so i'm putting it up here in case anyone else finds it useful.

It's actually as simple as clicking the "double-diamond" icon in chrome's address bar, in gmail, and choosing the "Allow chrome to open email links" option.

http://www.thegooru.com/how-to-open-email-mailto-links-in-gmail/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.