0

I use Geany for all my coding, in my linux Mint-MATE install. Occasionally, i have a problem where a non-breaking space (char code 194) is present instead of a normal space character (32). This just happened again and i'd swear that i didn't do anything special - i was just typing as normal. It's a real problem because the non-breaking space breaks (ironically) my Ruby on Rails interpreter.

Is there some key combination, like shift&space, alt&space, or something, that puts a non-breaking space instead of a normal one? I've been experimenting with key combinations but can't produce one on demand.

If there is some combination that makes the 194 space, can i disable this?

thanks, Max

EDIT - the plot thickens (maybe) - if i "inspect" this character (in ruby) i get "\302\240", which seems different again. From my (limited) understanding of character encoding, we've got the unicode char A0, which is represented in utf8 as C2 A0, which is then represented here as "\302\240". So, this might just be because my ruby environment, which i'm using to look at the characters in the string is utf8, so it's being translated. So, this EDIT might just be adding extra confusion - apologies if so!

1

Indeed, Geany is having an option to insert an alternative space. You can find the option inside the "Insert" menu and/or you can set a keybidng for it (inside the insert section of keybedings). In default there should be no keybinding set for.

  • Thanks. In the "Keyboard Shortcuts" page of geany's preferences, under "Insert" as you say, there is an option "Insert Alternative White Space". However, it doesn't have a keybinding set for it. – Max Williams Apr 15 '15 at 16:03
  • Hmm... it might be not the smoking gun you are looking for. Geany itself should not insert some strange characters. Are you sure you don't copy it in via some other text maybe? – frlan Apr 15 '15 at 23:57
  • yes, copypasta is definitely a suspect. It's looking more likely since the geany key combo is looking less likely. You pointed out the key combo to me, anyway, so i'll mark your answer as correct, thanks. – Max Williams Apr 16 '15 at 10:02
1

Some xkb mappings have the non-breaking space assigned to a combination of key (for instance AltGr-Space or AltGr-Shift-Space). Some compose database also have a mapping (Compose space space for instance). You may be hitting one of those involuntarily.

  • This is a promising lead, thanks, but the AltGr combos you mentioned both make a normal space for me. cheers tho :) – Max Williams Apr 16 '15 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.