I am trying to get the wireless card of my laptop (Broadcom BCM43142) to work under kali linux (latest version, 64bit). At the moment (without installing anything), it is not recognised at all. I have never installed any drivers on linux systems, so i have almost no idea what to do.

EDIT: after a lot of searching and following a lot of tutorials without success, I found this: http://www.chokepoint.net/2014/04/installing-broadcom-bcm43142-drivers-on.html

I followed it, and after I run the script I get this:

KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: Entering directory `/usr/src/linux-headers-3.18.0-kali3-amd64'
CFG80211 API is prefered for this kernel version
Using CFG80211 API
/usr/src/linux-headers-3.18.0-kali3-common/scripts/Makefile.build:397: *** missing separator.  Stop.
make[3]: *** [_module_/root/Desktop/drivers/broadcom#2/broadcom] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.18.0-kali3-amd64'
make: *** [all] Error 2
cp: cannot stat `wl.ko': No such file or directory
Error: Module bcma is not currently loaded
FATAL: Module wl not found.

this is the same i get if i run make again, in the folder the script downloaded. Anyone have any idea why this is happening?

3 Answers 3


Try this download from broadcom https://www.broadcom.com/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-6_30_223_248.tar.gz as it has the patches to work with the newer kernels


Try following the instructions on this site from 3. onward. Find the correct drivers for your network interface on https://git.kernel.org .

Here are the instructions from the site above:

3. Network driver

Once you finish installing, boot into Kali, and you will see network device is missing. Type in terminal:


There is only one "lo".

To fix this, download the firmware for macbook pro 2015 from here git.kernel.org...

Copy the file into /lib/firmware/brcm

Reboot and you will see WiFi is working, but still has no network access.

Start the network manager by modifying configuration file.

root@kali:~# nano /etc/NetworkManager/NetworkManager.conf

Turn false to true

root@kali:~# /etc/init.d/network-manager restart

Reboot and WiFi should work. This may not work on Thunderbolt-Ethernet wired network.

  • Welcome to Unix & Linux.  While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference.  Link-only answers can become invalid if the linked page changes. Oct 25, 2015 at 5:13
  • 1
    ok, I put it in ! cheers Oct 25, 2015 at 5:44

I'm using Kali 2016 rolling and have the same wireless card as yours.

root@Sierra ~ % lspci -vnn | grep Network                                       
06:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

And just like you I couldn't get my wireless detected. So after searching a lot on internet I finally installed broadcom-sta-dkms and loaded wl module into kernel.

sudo apt-get install broadcom-sta-dkms
modprobe wl

I got my wireless card detected and it supports promiscuous mode and packet injection too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .