1

After configuring hibernation to swapfile with this instruction https://wiki.debian.org/Hibernation/Hibernate_Without_Swap_Partition commands s2disk & pm-hibernate are work fine. However hibernation doesn't work with XFCE's button "Hibernation" from logout menu with error:

[ 2922.693779] PM: Cannot find swap device, try swapon -a.
[ 2922.694793] PM: Cannot get swap writer.

Where are to set proper commands for hibernation in XFCE?

1 Answer 1

0

Have you tried swapon -a, and the possible solutions after the how to? Maybe you don't have permissions to write the file, check if permissions are right and if you are in the powerdev group.

2
  • Yes, I tried swapon -a. What solutions are you talking about? I haven't powerdev group, should I create it manually?
    – qloq
    Apr 8, 2015 at 5:13
  • You should have a power group, though maybe is not called powerdev. I'm talking about the bottom of the page when it is described how to solve some possible problems Apr 8, 2015 at 12:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .