1

Since two days I'm struggling with making Gitweb work on my home server machine. I've modified so many configuration files till now, that I've decided to completely remove the Gitweb package from my server and start all over again. I've performed the apt-get purge gitweb command and then I've checked if there's still something in the file system that needs to be removed with find . -name gitweb command. It listed the /usr/share/gitweb directory so I've removed it with rm -R /usr/share/gitweb. Now when I'm trying to install the Gitweb packe from scratch I can't get the /usr/share/gitweb folder installed in my server. I've tried apt-get install --reinstall gitweb command, apt-get install gitweb, few times purged the package with apt-get remove --purge gitweb and apt-get purge gitweb, then I've updated the apt sources with apt-get update command in different sequences with the above commands but none of this ways solved my problem. Could you please help me to recover the /usr/share/gitweb folder as my Apache2 instance is not able to provide Gitweb service as this folder contained required CGI scripts to run the web app? I'm running Debian 7.8.

1

Using dpkg -c [gitweb-package.deb] in /var/cache/apt/archive/ I've noticed that contents of this package does not contain the files I was looking for, so I've checked the contents of git package and that is where I've found it, so the final solution is to reinstall the git package itself.

| improve this answer | |
  • This is exactly how I recovered mine as well. just running sudo apt reinstall git – m4l490n Jun 4 at 1:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.