1

I tried different Xen versions, the results are similar: vga-passthrough does not work. I can start a domU in hvm mode and connect with vnc but I cannot get it to work on my GPU

I did add the cards id to /etc/initramfs-tools/modules: xen-pciback passthrough=1 hide=(01:00.0)(01:00.1)

They are listed with xl pci-assignable-list

0000:01:00.0
0000:01:00.1

After I start the domU (in this case windows) they are no longer listed. In the log file I get the following which did not help me:

char device redirected to /dev/pts/2 (label serial0)
[00:04.0] xen_pt_initfn: Error: Binding of interrupt 0 failed! (rc: -1)
[00:05.0] xen_pt_initfn: Error: Binding of interrupt 1 failed! (rc: -1)
[00:04.0] xen_pt_region_update: Error: create new mem mapping failed! (rc: -1)
[00:04.0] xen_pt_region_update: Error: create new mem mapping failed! (rc: -1)
[00:05.0] xen_pt_region_update: Error: create new mem mapping failed! (rc: -1)
[00:04.0] xen_pt_region_update: Error: create new ioport mapping failed! (rc: -1)

My config file looks like this:

builder='hvm'
memory = 4096
name = 'bane'
vcpus=2
pae=1
acpi=1
apic=1
on_xend_stop='shutdown'
vif = [ 'mac=00:16:3e:68:ba:2e,type=vif,bridge=xenbr0' ]
disk = [ '/dev/raid/bane,raw,xvda,rw'  , '/mnt/iso/win/7/dvd.iso,raw,hdc,devtype=cdrom' ]
device_model_version = 'qemu-xen'
boot='dc'
sdl=0
vnc=1
#vncpasswd=''
serial='pty'
#tsc_mode=0
viridian=1
usb=1
usbdevice='tablet'
gfx_passthru=0
pci=[ '01:00.0', '01:00.1' ]
localtime=1
xen_platform_pci=1
pci_power_mgmt=1

I am running debian jessie/sid with xen-4.5 from experimental. Linux atlas 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt7-1 (2015-03-01) x86_64 GNU/Linux

I would like to get vga-passtrough working and I think the errors in the log file are relevant, but I am not sure.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.