0

I am trying to install PHP 5.4 on CentOS 7

currently , my conf files look like the following :

/etc/nginx/conf.d

server {
 listen       80;
 server_name  178.62.255.79;

 root   /usr/share/nginx/html;
 index index.php index.html index.htm;

 location / {
     try_files $uri $uri/ =404;
 }
 error_page 404 /404.html;
 error_page 500 502 503 504 /50x.html;
 location = /50x.html {
     root /usr/share/nginx/html;
 }

 location ~ \.php$ {
     try_files $uri =404;
     fastcgi_pass unix:/var/run/php-fpm/php-fpm.sock;
     fastcgi_index index.php;
     fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
     include fastcgi_params;
 } }

/etc/php-fpm.d/www.conf is as default except

listen = /var/run/php-fpm/php-fpm.sock

one thing to note is that when I looked into the directory /var/run/php-fpm/ there's a file named php-fpm.socks

the server can run http requests (nginx is working) , but when I try to browse a PHP file , it gives ,

The page you are looking for is temporarily unavailable. Please try again later.

I followed many instructions , they all said that I should change 127.0.0.1:9000 to php-fpm.sock , but it is not working too

setting both conf files to 127.0.0.1:9000 is not working , I think the data is not being received by FastCGI Process Manager

do you know any of the available solutions ?

thanks

  • @Christopher , I am using /var/run/php-fpm/php-fpm.sock , not /var/run/php-fpm/php-fpm.socks – Mike s Apr 7 '15 at 18:20
1

check your /etc/php-fpm.d/www.conf file and be sure to change the user and group from apache to nginx

user = nginx
group = nginx

then systemctl restart php-fpm.service and see if that helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.