1

My current multiseat config works fine, except for one thing : I cant access virtual terminal on either seat. I think it comes from the fact I launch X through my DM (LightDM) with the -sharevts switch, but unless I put this switch, I got the weird issue that seat1 gpu crashes when I logout seat0. Here is my /etc/lightdm/lightdm.conf

[LightDM]
minimum-display-number=0
minimum-vt=7

[SeatDefaults]
#greeter-session=lightdm-greeter
user-session=lightdm-xsession
exit-on-failure=true
greeter-hide-users=false

[Seat:0]
xserver-command=/usr/bin/X :0 -keeptty -sharevts
xserver-layout=seat0
xdg-seat=seat0
[Seat:1]
xserver-command=/usr/bin/X :1 -keeptty -sharevts
xserver-layout=seat1
xdg-seat=seat1

now when looking in processes, I see the -novtswitch option enabled on seat0, I got no idea who puts it here though :

➜  ~  ps aux | grep '/bin/X'
root     11770  0.0  0.4 371940 60364 ?        Sl   13:48   0:00 /usr/bin/X :0 -keeptty -sharevts :0 -layout seat0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
lotso    12619  0.0  0.0  12724  2236 pts/2    S+   14:23   0:00 grep --color=auto --exclude-dir=.bzr --exclude-dir=.cvs --exclude-dir=.git --exclude-dir=.hg --exclude-dir=.svn /bin/X
root     16612  0.0  0.2 305416 33252 ?        Sl   Apr06   0:00 /usr/bin/X :1 -keeptty -sharevts :1 -layout seat1 -seat seat1 -auth /var/run/lightdm/root/:1 -nolisten tcp

Ideally I'd like to have access to vt1 to 6 on seat0 and that seat1 got only it's X server running. Is that achievable ? Thanks for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.