I'm driving a Debian testing machine that is running fine. But since testing includes Linux Kernel 3 I have the following problem:

While booting all is working (I mean especially the keyboard) - controlled by switching NumLock state. The moment gdm3 starts (from init) the keyboard dies... It can only be reanimated by killing gdm3 (I do this via ssh). Running startx from console behaves fine, thus the "xorg.conf" seems to be fine.

The output from startx reads as

X.Org X Server 1.10.3
Release Date: 2011-07-08
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.0.0-rc6-amd64 x86_64 Debian
Current Operating System: Linux sobolev 3.0.0-1-amd64 #1 SMP Sun Jul 24 02:24:44 UTC 2011 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.0.0-1-amd64 root=UUID=7d005ab3-c823-4cc9-b70a-9316a5eab8d6 ro quiet
Build Date: 07 August 2011  06:45:11PM
xorg-server 2:1.10.3-1 (Cyril Brulebois <kibi@debian.org>)
Current version of pixman: 0.22.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug 26 09:19:48 2011
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] Kernel modesetting enabled.
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server

Any ideas? I'm using a PS/2 keyboard and USB mouse. The mouse is alive under gdm3.

  • 1
    I'm curious about how do you kill gdm3 without a working keyboard. – enzotib Aug 26 '11 at 8:00
  • @enzotib Login via ssh is working fine... ;-) – Bastian Ebeling Aug 26 '11 at 8:19

This happens typically when you upgrade your Xorg server without upgrading/re-installing the xorg keyboard drivers afterwards. This is contained in a separate package - on Gentoo it is xf86-input-keyboard, on Debian (according to Gilles' comment below) the name should be xserver-xorg-input-kbd . Try upgrading/re-installing it.

Edit : Merged the package name information from Gilles' comment.

  • On Debian squeeze, the package name is xserver-xorg-input-kbd, and -mouse for the mouse. – Gilles Aug 27 '11 at 17:36
  • @Gilles and rozcietrzewiacz: Thanks for those details. I found those packages, too - and installed them - but that solved not my problem... Any further ideas? – Bastian Ebeling Aug 28 '11 at 18:28
  • 1
    Oh, so the startx works fine... Then gdm is probably broken :/ But first try to boot the same system with an older kernel (since you mention the kernel upgrade). – rozcietrzewiacz Aug 28 '11 at 19:04
  • Hi - the problem is solved. After reinstalling gdm3, x-server-xorg und the xserver-xort-input-* drivers, the problems remained. I tried logging in with screen-keyboard and found the last option Only accept long keystrokes (keyboard lag) (in menu for disabled users) activated. Disabling of course did it. Thanks for all help! – Bastian Ebeling Aug 29 '11 at 5:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.