0

I'm running Linux Mint 17.1 on my old desktop pc. Since I moved, I had no internet connection, but could use the WLAN of my neighbors. For that, I had to install an old FRITZ! USB WLAN driver. I did that by downloading a bunch of required packages via a WLAN capable notebook, copied the deb-files to the pc and installed them via

sudo dpkg -i

Here are the packages that I installed during the offline installation:

  • ndiswrapper-common_1.59-2_all.deb
  • ndiswrapper-dkms_1.59-2_all.deb
  • ndiswrapper-source_1.59-2_all.deb
  • ndiswrapper-utils-1.9_1.59-2+b1_i386.deb

and the packages that I additionally installed to solve dependency problems:

  • dpkg-dev_1.17.24_all.deb
  • po-debconf_1.0.16+nmu3_all.deb
  • module-assistant_0.11.7_all.deb
  • html2text_1.3.2a-18_i386.deb
  • libdpkg-perl_1.17.24_all.deb
  • libstdc++6_4.9.2-10_i386.deb
  • gcc-4.9-base_4.9.2-10_i386.deb

The WLAN-driver worked. The problem is, I installed package versions, that are newer than the current Ubuntu packages. Since then, I can't get updates anymore due to a broken package (libgcc1).

Now, I have a wired LAN connection again and I want to fix the problem. When I run

sudo apt-get install -f

apt wants to remove a bunch of packages and I get the message "You are about to do something potentially harmful"... This is not what I want to do ;)

All I want to do is to get my old system back, which means all packages in the current Ubuntu version (trusty-updates). How can I achieve this?

0

In the meanwhile I solved my problem by means of the following steps

  1. I checked the synaptic package managing tool for the installed and available versions regarding the mentioned packages
  2. I then downloaded the versions tagged with (trusty) or whenever a (trusty-updates)-version was mentioned the trusty-updates version. The command was sudo apt-get download ndiswrapper-dkms=1.59-2 ndiswrapper-source=1.59-2 ndiswrapper-utils-1.9=1.59-2 dpkg-dev=1.17.5ubuntu5.3 po-debconf=1.0.16+nmu2ubuntu1 module-assistant=0.11.6 html2text=1.3.2a-17 libdpkg-perl=1.17.5ubuntu5.3 libstdc++6=4.8.2-19ubuntu1 gcc-4.9-base=4.9.1-0ubuntu1 The files could then be found in the current working directory, which in my case was the home-folder
  3. Then I installed the downloaded packages with sudo dpkg --force-all -i /CurrentWorkingDirectory/*.deb

Everything works again :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.